CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   'Tetrahedral meshing has failed for volume...' (

Murat February 6, 2009 17:14

'Tetrahedral meshing has failed for volume...'

My question is related with Gambit. I am doing some modifications on 3D truck model. One of this modification is adding side mirrors to truck. I created the side mirrors on truck geometry and meshed the all surfaces of side mirrors one by one. Then i wanted to create volume mesh on the geometry but it did not mesh the volume and it gave an error on the text screen of Gambit like this; "Tetrahedral meshing has failed for volume v_volume.57. This is usually caused by problems in the face meshes check the skewness of your face meshes and make sure the face mesh size are not too large in areas of small gaps."

Before adding the side mirrors to truck geometry, there were no error on meshing the volume. So, i guessed that the error was related with side mirror geometry. But, although i check both faces and face meshes of side mirror geometry, there is no error message related with them. Furthermore, what can be the reason for not meshing the volume? What can i do to mesh the volume?



zongtwi February 9, 2009 21:07

Re: 'Tetrahedral meshing has failed for volume...'
Try using size functions around the side mirror geometry. See if that would help.

Murat February 10, 2009 01:45

Re: 'Tetrahedral meshing has failed for volume...'
I tried size functions but this time Gambit gives error message like that: " TG_Mesh Domain failed with error code 1. A size function is already associated with the following entities, thus the required uniform mesh size is ignored during meshing"

I did not understand what this message mean. Before i did not try size funtion on geometry but the error message mentions like that.

zongtwi February 10, 2009 04:49

Re: 'Tetrahedral meshing has failed for volume...'
Well, it is hard to troubleshoot your case without seeing the problem first hand.

I would recommend re-meshing your case from scratch. Do a 'Reset Mesh' in the command line, and mesh your edges, surfaces and volumes again. Ensure that your sizing are all similar to the previous case if you want to compare the two results together.

Hope that helps.

mAx February 10, 2009 07:36

Re: 'Tetrahedral meshing has failed for volume...'
you should have an small egde somewhere

onionmon February 19, 2011 05:22

I had the same error. I discovered a vertex from one surface that was very close to another surface so that a 3D tet element was not able to be created during 3D meshing. The vertex closeness to a surface is shown in a rough diagram below.


|-----|    |-----|
|      |_._|      |

See if you can find a lone white vertex (multi-edged vertices are purple) sitting by itself anywhere in your model. Zooming out may help. I then created a geometry and boolean-subtracted it from my base geometry so that the vertex was removed. Then I was able to mesh.

All times are GMT -4. The time now is 18:45.