CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   problem with display (

john March 11, 2009 17:45

problem with display
hello when i first read the case file and then select display and then select grid,fluent shows my grid properly,but if i try to expand the grid window nothing happens or if i close grid window and try to open it again it will not open again and gives this error: "Error: FLUENT received a fatal signal (SEGMENTATION VIOLATION). Error Object: ()" any ideas why i get this error thanks

Laci March 11, 2009 17:51

Re: problem with display
Which OS do you have? Win Vista?

john March 11, 2009 18:12

Re: problem with display
no,windows xp,do you think the problem is from my os?

john March 11, 2009 18:15

Re: problem with display
the problem has gone further too!when i itterate and then want to display vectors or countors it gives this error:"Error message from graphics function Set_Camera_By_Volume: Xmin is equal to or greater than Xmax"

maxim March 12, 2009 04:08

Re: problem with display
Hello some questions which may help:

did you check your grid? Did you scale your model? are you using Fluent in parallel processing?

Check these points, it can solve your problem..

Matt March 12, 2009 10:41

Re: problem with display
This is a cortex problem.

Load Fluent with:

fluent 3D -serv

and see if this fixes your problem.

It should (loads the parallel code instead which I think gives Cortex its own address space...specifics don't really just works).

This is a Fluent-on-Windows problem.

john March 12, 2009 15:41

Re: problem with display
i tried "fluent 3D -serv" ,but when fluent window comes up it sayed: [Unable to execute e:\\fluent6.0\ntx86\3D\fl6012.exe "e:\\fluent6.0\ntx86\3D\fl6012.exe" -cx a-2bc8454b00f44:1899:1900 The system cannot find the file specified.], i went to that folder and saw the name file was f16012s i renamed it to f16012 and again ran fluent 3D -serv this time it sayed: [Loading "e:\\fluent6.0\lib\fl114.dmp" Done.],then i tried to read a case file but it gives this error:[there is no active application],is it possible that the problem occurs because my processor is multiproccessor intel q6600 or because of opengl problems?cause untill one month ago i had a single proccessing proccessor AMD 2400 and geforce 7200 then i changed them and the problem occurs.

Matt March 14, 2009 12:31

Re: problem with display've gone outside of my experience here.

Reading the messages it looks like an install problem(?) The .dmp message is normal.

Make sure your PATH is set to find fluent. also make sure FLUENT.INC environment variable is still set.

f16012s is the serial executable I think, which is should not be loading if you designate -serv, but really you should not have to rename it/find it/worry about it.

I am running on multiprocessor (4 core) intel no problem (well, at least not the problem you describe...) , and across a network as well to multiple other machines in parallel

The process should show up under task manager as fl****.exe where the stars are the version number. (no 's' at the end if loaded with -serv).

You might want to seriously considering upgrading to the latest stable version - 6.0.12 was painful to use on Windows and may be a lot of the problem. 6.3.29 is not much better...but some of the weirdness is gone (note that you can't use 6.3.29 with the HP interconnect under windows 64 and MPICH takes a serious speed hit, so you'll have to ask support for a beta release if you are going 64 bit parallel)

Are you intending on using 32-bit? It should be loading from the 64 bit binaries (win64) and not the ntx86 directory if you are going to run 64 bit.

Hate to say it, but my best guess at this point is to uninstall totally, download a newer version, and re-install. Critical that PATH and FLUENT.INC are set correctly. Make a shared directory if you are going to run parallel code. I share directly from the IP address (fixed in my case) and not from a mapped drive:


Finally, I have as many problems with the opengl drivers as the win drivers that come packaged with it...have to switch back and forth depending on which bug you want to avoid. You can change after fluent is already loaded with:

/display/set/rendering-options/driver msw null opengl

But in general the grfx 'work' if I load with -serv.

Matt March 14, 2009 12:40

Re: problem with display
Also, reading back in the previous posts, some others had good suggestions about looking for grid strangeness. The velocity vector problem particularly suggests there may be a grid issue.

All times are GMT -4. The time now is 09:18.