CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Running fluent in UNIX (

L3munoz August 25, 2009 05:23

Running fluent in UNIX
Hi everybody!

I have a problem and I'd be very grateful if someone could help me...

I'm working with UNIX and I want to run FLUENT. According to what I found, if u write

fluent 3d

is enough to start a 3d-fluent session, something very easy. However I cannot. Whenever i write it it gives me a message on fluent telling me it wasnt possible to connect any license. However, when i write just fluent and then in the launch window i select 3d version it works, so it means there isnt any problem related with number of licenses and so on.

I'm wondering if there is something i should have activated to open fluent by the command fluent 3d cause...

I called the FLUENT technical support and they told me something about environmental variables... Do you have any idea??

Please, i really need help cause i dont know what else to do...

thanks in advance,


mohsen zendehbad August 25, 2009 05:40

if possible tell me what your supporter has told you, you should write a line, which probably the supporter has told you, in your .bashrc file.

L3munoz August 25, 2009 05:47


Sorry but i cannot understand u...what do u mean?

If u want i can put what the supporter told me in the mail, but it's in spanish...he told me to check if the following environmental variables were activated
name : FLUENTLM_LICENSE_FILE y value: 7241@nameofserver
name:ANSYSLMD_LICENSE_FILE y value : 1055@nameofserver
name:ANSYSLI_SERVERS y value : 2325@nameofserver

He told me as well to see if there is any variable named LM_LICENSE_FILE. In this case i should delete it. The point is that i dont know how to check them and delete/modify them...

can u help me?


mohsen zendehbad August 25, 2009 06:00

dear Jorge
I have worked with linux cores, I am not sure whether these commands are the same in linux and unix or no, but at least you have the chance to try it, in your command line write
-gedit .bashrc
This way you will open your .bashrc file. This file is where you should write your environmental variables and save it. Then by rebooting your computer your problem may vanish.
e.g. In linux we write the following line in .bashrc to assign the variable, ANSYSLMD_LICENSE_FILE, with its value:

L3munoz August 25, 2009 06:05


First, sorry but i think it's Linux and not UNIX what i'm working with (Red Hat), so it's good. Then i tried what u told me, writing in the bashrc file and I could, but what about deleting the other variable? how could i do that??

mohsen zendehbad August 25, 2009 06:11

all variables should exist in your .bashrc file. if there isn't any that means that such variable doesn't exist.
if you have defined variables correctly, when you write the following line in the command line its value should be shown.
-$(the name of the variable with upper case)

L3munoz August 25, 2009 06:17


I included here what is written in the bashrc file. As u can see there is nothing but what i've just written. about checking the value fo the new variables i tipped "echo $VARIABLE" and it worked.

# .bashrc
# Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
# User specific aliases and functions

Is there any way to see if the other one (LM_LICENSE_FILE) exists?

And another thing. My desire is to be able to open fluent in unix by writing the command fluent 3d as it should be, but it doesnt work. What is the solution?? Because maybe this isnt the solution and we're spending time on other topic...Sorry but i'm quite new with linux/unix world and this is why i'm asking all this stuff...

thanks a lot for ur help Mohsen.

mohsen zendehbad August 25, 2009 06:37

the thing i know is that the variable is not defined when it is not in your .bashrc file. you'd better send me the complete error you get when you try running fluent. i'll work on that and next time i log on i'll let you know if i got any result.

L3munoz August 25, 2009 06:47

HI Moshen,

Thanks a lot for ur help. Please, find attached the scans where u can see the error. The first one is related to what i write, as i told, just the command "fluent 3d". Then, in the second one u can see the error FLUENT gives. I also include the FLUENT variables obtained when u write "fluent 3d -env".

Any help is welcome, so i'll wait for ur advice,


mohsen zendehbad August 26, 2009 04:15

the only thing i could find for you is try running fluent by writting the following command in your command line:
-fluent -x11


L3munoz August 26, 2009 04:59

Hi Moshen!

What u've just proposed is what i wanted to avoid. I mean, typping -x11 opens a launch window where u define the session u want to work with. What I wanted was to write the command in the shell in order to not work with the interface. However, dont worry anymore. The problem is solved. I managed it and now it works perfectly.

Thanks a lot for ur help and attention.



All times are GMT -4. The time now is 01:46.