CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Parallel communication problem, port 8676 (

jreig September 4, 2009 06:00

Parallel communication problem, port 8676
hi everyone,

I'm trying to connect 2 pcs in order to launch parallel fluent. I am having problems in only one direction, I mean, if I use "pc1" as the host and "pc2" as the node 1, everything works fine; but if I turn the other way around, using "pc2" as the host I get the next error:

abort: Unable to connect to 'pc1:8676',
sock error: generic socket failure, error stack:
MPIDU_Sock_post_connect(1200): unable to connect to pc1 on port 8676, exhausted all endpoints (errno -1)
MPIDU_Sock_post_connect(1247): unable to connect to pc1 on port 8676, No se ha podido establecer conexión ya que el equipo de destino ha denegado activamente dicha conexión. (errno 10061)

I've already tried to turn the firewall off, and to open this port, but it still doesn't work.

I am using MPICH as the network communicator.

the thing is that I don't wanna use any of these computers in my final parallel calculation, but I have the same problem when using the computers that I will use for the real calculation, and in this case, in both directions.

please help me!! :D
thanks in advanced

vincentk May 25, 2010 18:20


Actually I'm tying to do the same and always blocking on this problem (port 8676).
Can you explain how you did for the case that is working?

I mean, how do you run fluent ? "C:/.... 3d -t2 -cnf=.... -path\\ etc...
What does you hosts.txt file look like?

Mine is like this:


for my both computers is shared on both PC.
I do activate port 8676 on my router and no firewall on both PC

Did I miss something, or did something wrong?

Thanks for your help. I'm currently still searching for solution, if I find out, I will let you know. Since then, good night.

jreig May 27, 2010 20:30

Hi vincentk,

I am sorry but I left the company where I was working on this issue and it was never solved as far as I know. So I can't really help you.

Anyway, if you find the solution, please let me know cause it may be useful in the future.

vincentk May 28, 2010 02:24

Thank you for your answer.
After fiew days since I left this message, I think that the problem solution seems to be in the setting up of the MPICH2 software. This one, is actually, as far as I know, establishing the communication network among processors.

Best regards,


All times are GMT -4. The time now is 23:13.