CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   parallel mode failure in 3ddp but not in 2ddp (

ak6g08 September 22, 2009 06:17

parallel mode failure in 3ddp but not in 2ddp

I have been using 2ddp mode in FLUENT to simulate a problem which involves two UDSs and some other source terms on the momentum equation, so far everything has worked fine in 2d, both in serial and parallel mode. The domain is a simple square, top and bottom boundaries are walls, left and right are a periodic pair. I now want to run a 3d problem, which is a cube, so that now the top and bottom faces are walls and the other 4 boundaries are periodic pairs. When I run the problem in 3ddp serial it is fine, however in 3ddp parallel the following error comes up, its strange that it works in 2ddp in parallel but not in 3ddp, does anyone know why?:

received suspend command for a pmi context that doesn't exist: unmatched id=1

999999(..\..\src\mpsystem.c@1123): mpt_read: failed: errno = 10054

999999: mpt_read: error: read failed trying to read 4 bytes: No such file or directory

The Parallel FLUENT process could not be started

Thanks a lot

ak6g08 September 22, 2009 06:56


I seem to have found the solution to this problem for those interested, the following command had to be issued:


and then answering yes to freeing temporary memory and to allowing all applicable discretisation schemes, the problem only failed in parallel when I chose a second order discretisation scheme for the UDSs it turns out...which is slightly odd, if anyone knows why this is, it would be helpful to know for future reference.


All times are GMT -4. The time now is 08:27.