CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   fluent 12.1, batch mode in linux (

sakalido May 3, 2010 13:17

fluent 12.1, batch mode in linux
Hi all,

I am trying to run fluent 12.1 in batch mode using linux, ubuntu 8.04 and I am using the following command:
fluent 3d -g -i fluent_jou.txt > pressure_outlet_tec.dat 2>&1 &

fluent opens with the start up window ( although I have specified no graphics !!! ) and doesn't do anything.
Even, buy dropping -g, fluent does not read my journal file using this command:
fluent 3d -i fluent_jou.txt

basically both above commands behave the same.
can anybody tell me what is wrong ?

dmoroian May 3, 2010 14:25

Use -gu, but you have to post the content of the fluent_jou.txt!

sakalido May 3, 2010 14:55

1 Attachment(s)
Thanks dmoroian for the reply.
I have used -gu as well but it does not work.
I don't think the problem is with my journal file because when I open fluent and read the journal file, It runs without any problem.
What does not work is the command I am typing in the terminal apparently.

I also uploaded the .jou file, it is a very simple one.

Thank you for your help

dmoroian May 3, 2010 16:02

I had a glimpse of your journal file, and is characteristic to a recorded macro from the gui. How do you expect it to work without a gui?
You have to rewrite it again using only tui commands.

sakalido May 3, 2010 17:54

I see. I am new to fluent and I might have very basic problems.
for TUI do I need to type the commands I am using in a text editor ?
There is no other way to create a TUI, right ?
I mean when I choose to "start a journal file" in fluent, it makes a GUI journal file by default, right ?

I already have the first problem that when I type "file>" and enter, there is no option to read the mesh. and "/file/read/mesh grid.msh" does not work either.

Thank you again for your help, I really appreciate it.

dmoroian May 4, 2010 01:36

Yes, the most common way to generate a journal file is to use a text editor.
To read in just a mesh, try: "file read-case file.msh"

sakalido May 4, 2010 13:09

problem with running TUI journal file in batch mode using linux
Dear dmoroian,

Thank you again for your help.
I made the TUI journal file, but again I have the same problem as before. When I open fluent and read my TUI journal file, it reads it without any problem. However, in termina when I use fluent 3d -g -i fluent_TUI.jou > pressure_outlet_tec.dat 2>&1 & it does not work. what can be the problem ?
As there were some problems with attachments, I copied my TUI journal file bellow.


file read grid_jou.msh
mesh scale 0.001 0.001 0.001
mesh check
define models energy y y n
define models solver pressure-based y
define models steady
define models viscous ke-standard y
define boundary-conditions velocity-inlet inlet1 n n y y n 26 n 300 y n 1 n 1
define boundary-conditions velocity-inlet inlet2 n n y y n 26 n 300 y n 1 n 1
define boundary-conditions velocity-inlet inlet3 n n y y n 26 n 300 y n 1 n 1
define boundary-conditions velocity-inlet inlet4 n n y y n 26 n 300 y n 1 n 1
define boundary-conditions fluid body n n n y 0 0 0 0 0 1 n n n
define boundary-conditions pressure-outlet outlet n 0 n 300 n y y n 1 n 1 n n
define boundary-conditions wall shell 0 n 0 n n n 0 n n n n 0 n 0.5
define materials change-create air air y incompressible-ideal-gas n n n n n n
define operating-conditions reference-pressure-location 0 2.5 0
solve initialize compute-defaults all-zones
solve iterate 400
file write-case-data
file export tecplot 1 total-pressure q

dmoroian May 5, 2010 10:51

Hi Sara,
At first glance, your script looks ok.
I'm guessing that you have an alias for fluent that overwrites your options. Try at the command prompt "alias", and see if it returns an alias for fluent.


sakalido May 5, 2010 12:00

alias ?
Hi Dragos,

I am not familiar with aliases. I read a little about them. I get the list bellow and I do not see anything related to the problem. can you give me a hint what is alias ? which one do you think is related to my problem and how I can fix it ?
here is the list:
bzif bznf bzic bznc bzi bzn lzif lzic lznf lznc lzi lzn lchdir chdir sync-chdir lls ls lpwd pwd cortex-pwd error source . alias it cwd wd wc rcd rd rc

Thank you veryyyy much for your help again :)

dmoroian May 6, 2010 03:37

Ok, your list doesn't make too much sense for me either.
Let recap, and do it from the beginning. Execute the following commands in a shell, and post the result here:

1. cat /etc/issue*
2. echo $SHELL
3. which fluent
4. fluent -h
5. fluent -r

mbell10 June 16, 2010 08:54

the -i switch is used for windows. you need the command..

fluent 3d -g < fluent_jou.txt > pressure_outlet_tec.dat 2>&1 &

also, there is an error, there is no command:
define models steady

in fluent 12.1.. at least, not on 12.1.4.

alligngr8 January 9, 2012 13:39

Urgently Help required: Fluent Batch Mode reg
1 Attachment(s)
I am trying to run fluent in batch mode on windows platform. for that I have written batch file as

fluent -g -i case.jou

Howe ever when I run this batch file fluent starts its launcher, reads the journal file. Till that steps it works fine.But after that I need to manually press 'OK' to start fluent.
I have attached snap shot of what I am getting on running the batch file(also in image)

I have tried fluent 3d -g -i case.jou as well as
fluent 3d -gu -i case.jou but in both case same prob.

In fact when I write 3d or 3ddp in in front of -g and press "OK" to start running fluent it shows error that command 3ddp or 3d not recognized. So I intentionally have removed 3d.

But how to counter this.
I mean how to automate that I may not have to press "ok" again and again for multiple cases
Please guide its extremely urgent


Gwench May 3, 2016 08:16

Hello everyone,

I have exactly the same problem.
In C-shell, my command is "fluent 3d -g < imput.jou > & output &".

But when I press ENTER, the Fluent Launcher appears, although it should not because I disable the GUI with -g.
Two options are then available : OK or CANCEL. When I press OK, Fluent appears in GUI mode... When I press CANCEL, the C-shell is back.

Does anyone have an answer ?

Thank you in advance.

All times are GMT -4. The time now is 00:29.