CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   1.#qnb (

marye June 10, 2010 05:34


when I run my program, it stops at 3 iterations and on Fluent I can read "solution is converged"
and I have 1.#QNBe+00 that appears...

Does anyone know why?

I replace my real by float but it doesn't change the result.

Ethan August 8, 2010 18:38

Hey, I am getting the same problem with 1.#qnb. I was wondering how did u replace your real by float?


arslan July 31, 2012 17:32

i had the same problem
the problem i solved was a very simple: axissymmetric (horizontal) channel. I set up a axis BC at the upper boundary of my channel and get this error:

iter continuity x-velocity y-velocity time/iter
! 1 solution is converged
1 1.#QNBe+00 1.#QNBe+00 1.#QNBe+00 0:00:12 999

when i change: the upper boundary set a Wall BC, and the bottom set the Axis BC all fixed and a solution was gone..:)
I've heard before that Axis BC must be only seems that this boundary must be also a lower my simple geometry at least))))

hope that it will be someone..)))

pakk November 15, 2013 13:07

For those who were directed to this forum by google searching for "QNBe":

1.#QNBe+00 is what Fluent shows when it really does not know what to do, for example when somewhere in the calculation there was a 0/0.

In floating point operations, 0/0 results in NAN (Not Any Number). In Fluent, this is #QNAN. Fluent wants to represent this in exponential notation:
The next thing that happens is that Fluent wants to represent is with 4 digits. N is bigger than 5, so the A is rounded up to B, and it becomes

If you see this, it means that something in the calculation went wrong. It can have many, many different causes.

flotus1 November 16, 2013 06:52

In this specific case, people really should have read the manual.
It clearly states that the axis of symmetry in an axisymmetric simulation has to coincide with the x-axis.

hem233 November 19, 2013 14:35


In my case, #QNB is coming after around 3500 iterations. So how can I know what is going wrong?

All times are GMT -4. The time now is 09:47.