CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   How to install Fluent on Red Hat (

Sale October 20, 2010 06:30

How to install Fluent on Red Hat
Hello everybody,

I'm experiencing trouble installing Fluent 6.3 on Red Hat 5.5
I always used Fluent on WIndows, now I want to move to Linux, but I have no experience.
This is what I did:

I installed Fluent in the folder /home/Sale/Fluent.
Then I went in the folder /home/Sale/Fluent/Fluent.Inc/bin and I wrote ./fluent
I had this error message:

/home/Sale/Fluent/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26
Error: directory /home/Sale/Fluent/Fluent.Inc/fluent6.3.26 does not contain a valid arch.
Set the environment variable FLUENT_ARCH and try again.

After that I wrote:

an then

At this point if I write ./fluent I obtain:

/home/Sale/Fluent/Fluent.Inc/fluent6.3.26/bin/fluent -r6.3.26
/home/Sale/Fluent/Fluent.Inc/fluent6.3.26/cortex/lnia64/cortex.3.7.3 -f fluent (fluent " -alnia64 -r6.3.26 -path/home/Sale/Fluent/Fluent.Inc")
/home/Sale/Fluent/Fluent.Inc/fluent6.3.26/bin/fluent: line 4668: /home/Sale/Fluent/Fluent.Inc/fluent6.3.26/cortex/lnia64/cortex.3.7.3: cannot execute binary file

Can anyone help?
Is there any applications missing (I just formatted the pc and perhaps there is something still not installed)?

Any advice could be very helpful.

Thanks in advance

IvanCFD January 25, 2011 04:43

Hi Sale,

I am very interested if you have managed to install Fluent on Red Hat and where you got the installer from.

I have switched to Red Hat and would like to put Fluent on it.



Sale January 25, 2011 12:39

Dear Ivan,

I don't know why, but at the end I installed Fluent_install-lnx86-6.3.26.tar instead of Fluent_install-lnia64-6.3.26.tar, even if it is 64 bit platform.
The I set the environment variable in the following way:

In this way it works.


IvanCFD January 25, 2011 13:06

Hi Sale,

thanks for the information. I have Red Hat 64 bit, so I guess it should work.

One last quick question. To install Fluent, do you just type in the terminal this?

$ Fluent_install-lnx86-6.3.26.tar
$ export FLUENT_ARCH

is that all??

Thanks a lot beforehand.



Sale January 25, 2011 13:34

Not exactly.

I did in this way:
I downloaded Fluent_install-lnx86-6.3.26.tar
then I went in the directory where I downloaded the file and I umpacked it:
tar -xf Fluent_install-lnx86-6.3.26.tar

Now it should work.


IvanCFD January 25, 2011 15:21

Hi Sale,

sorry to bother you again.

I am quite a newer in Linux and still find it difficult to deal with. I have unzip the .rar file and I can see the .sh file has been created.

However, in that folder, if I type what you say (, Linux returns this:

bash: command not found

I have also tried this:


and Linux returns:

bash: ./: is a directory

Can you guess what I am doing wrong?




IvanCFD January 25, 2011 15:55

Hi Sale,

I have managed at last to do all the operations you have indicated.

However, when I go to ./Fluent.Inc/fluent6.3.26/bin/

and type fluent or fluent -r6.3.26, Linux returns:

bash: fluent: command not found

The thing is I actually can see that the fluent file (or command, or whatever it is) is indeed in /Fluent.Inc/fluent6.3.26/bin/

I am sure I am doing something silly...



Sale January 26, 2011 04:34

You have also to di the following:
export PATH=WhereTheFolderIs/Fluent.Inc/bin/:$PATH
and then, if everything is ok:
fluent -driver x11

I am also new to Linux. I am just tring to explain what I did and what worked for me.


dokuzoguzlar February 24, 2011 17:23

Hi Ivan

try ./fluent instead of fluent in bin directory

or try this to work in 3d: ./fluent 3d in bin directory again.

if it says something about FLUENT_ARCH, then type


now you can usr fluent with ./fluent command

All times are GMT -4. The time now is 13:25.