CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   Error with parallel computing: MPI (

therandomestname April 10, 2011 22:18

Error with parallel computing: MPI
1 Attachment(s)
Hello all:

This is my first time using FLUENT and I know little about the computing aspect of the program. I am working on a biomass gasifier simulation. I ran a few basic simulations without my UDF library and had no problem. However, when I tried to run the simulation using the UDF, (just one UDF for a volumetric reaction rate) I got the following error:

999999 (..\src\mpsystem.c@1148): mpt_read: failed: errno = 10054

999999: mpt_read: error: read failed trying to read 8 bytes: no such file or directory
MPI application rank 0 exited before MPI_Finalize() with status -1073741819

I also attached a screen shot.

I do not really know what this means. I am running 64 bit windows on a University network, if that explains anything. I do not think parallel computing is absolutely necessary, but when I turned on serial computing I got another error, ACCESS VIOLATION.

Any thoughts? Thanks in advance.

DSMeck June 28, 2012 04:12

This is exactly the same error I get from Fluent.
My UDF works fine in every of my cases. But now I get this mistake in one special caes. The only thing I changed is the ID of the domain and I adapted my UDF.
Did you find a solution of this error or did anyone else?

All times are GMT -4. The time now is 11:18.