CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   DPM parallel is not working but serial is working (

johnwinter May 27, 2011 05:13

DPM parallel is not working but serial is working
Hi All,

I am working on fluent 6.3.26. When i launch a case with 40000 particles for simple 3ddp parallel case in Windows7 64-bit mechine with 2/4/6/8 cores. It just got stuck for infinite time and it is not working. The same is working for 5000 particles (50*100 is ok but 400*100 is not ok).

40000 particles case is working in serial mode on the same mechine.

Simulation is unsteady with 0.01sec time step.

Any clues??

Peter023 March 27, 2012 02:01

the similar problem
Hello John,

I have encountered the same problem as you did. I run Fluent on Win 7 x64, steady simulation with unsteady particle tracking. I use UDF to inject particles into the domain. I use UDF to customise Body Force and Source terms as well. To get data, I write sample files (sample planes) and automatic, every steady iteration (not DPM) particle track file (XML, for CFD-post).

After starting the simulation, everything seems normal but after some time (random), the simulation gets stuck and does no proceed. The problem does not appear in serial case, only when running Fluent in parallel 2,4 cores.

Using different models (meshes) the situation differs, sometimes the simulation can be finished and sometimes not.

I really have no clue how to solve this problem, there is seemingly no pattern for this problem. I only know that it is not caused by my UDFs (tried on different geometries with success) or mesh partitions (particles did not even reach the boundary when the problem appeared).

Any solution for this problem?


All times are GMT -4. The time now is 21:32.