CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   3D skewness problem (

Santos-Dumont August 1, 2011 16:16

3D skewness problem
Hi everybody,

I've been working on a problem that's been blowing my mind for the day.

I'm meshing an aircraft (Dassault Falcon 50) equipped with a pod, a mast and a turret under the fuselage. I managed to run some pretty nice simulations with the fuselage, the engines, the pod and the wings. And I get a 2% difference with the lift results from Dassault, which is pretty cool.

Still, I now added the turret, the mast and the horizontal stabilizer, but I'm not able to mesh it anymore.
With my various results and after a lot of patient geometry cleaning, I'm eventually able to mesh the faces of the aircraft using Tri Elements with a maximum skewness of 0.87, using a size function.

But when I mesh the Volume with TGrid, something that was previously a walk in the park, I get the message saying that the Tetrahedral mesh failed and asking me to check the skewness of my faces. But after a lot of checking, I still can't see the problem.

I tried everything, with or without size function, I cleaned my geometry to the maximum, but nothing works... The thing is I can't check the skewness of the volume mesh simply because no volume mesh is created, so it's not possible for me to spot my problem. I really don't understand how Gambit fails to mesh the volume even though the faces are fine.

I wonder if any of you had experienced a similar problem and if you have a clue for my problem...


-mAx- August 2, 2011 00:54

Once you get the skewness message, go to examine mesh.
select 2d, and enable worst element.
Gambit will dsplay the worst 2d element from your surface mesh.

Santos-Dumont August 2, 2011 04:33

Thanks Max,

I still get that message and my worst 2D element lies with a value of 0.866161, which is not that high.

So that wouldn't be the problem right ?

-mAx- August 2, 2011 04:50

don't know there could be many resons for that.
If you increase the quality on your surface mesh, does it fix your problem?
If you want I can take a look at it

Santos-Dumont August 2, 2011 05:16

No unfortunately in some regions if I refine the mesh I get more Equisize Elements... I really do not understand

-mAx- August 2, 2011 05:29

If you want to share your dbs you can send me a private message

*Else does Gambit involve any surface id while returning Warning Message?

*A rudimentary way to localize where are problem, is to split volume and mesh.
If your volume mesh failed, split the volume again, and mesh...
Etc... untill you identify the problem

Santos-Dumont August 2, 2011 07:41

I can't share my .dbs because of copyright issue. I noticed that I had a count of the failed nodes. It's very annoying because it's written : "Initialization failed to mesh 3 nodes"........................

Santos-Dumont August 2, 2011 07:47

I also tried refining but I get a memory overload. I can't really simplify more my geometry, I'm out of ideas...

-mAx- August 2, 2011 07:48

try last point from my previous message

Santos-Dumont August 8, 2011 03:42

I finally find out the source of my problem. I had a problem with my geometry. I removed my wing tips (they wasn't very good with CATIA) and the number of failed nodes dropped from 3 to 1. I also made a small cut on the rear of the mast in order to have an extra surface and reduce the sharpness of the angle on the trailing edge of the mast. And everything work fine now. So it was mainly a geometry problem. I hope it will help someone facing the same problem.

All times are GMT -4. The time now is 19:40.