CFD Online Discussion Forums

CFD Online Discussion Forums (
-   FLUENT (
-   -   MPI and Access Violation Errors (

Cypher August 28, 2011 17:09

MPI and Access Violation Errors
Hello all,

I have recently run into a frustrating problem in Fluent 13, where it refuses to write cases and data. The meshes I tested did not use any user defined functions, nor libraries. At first I thought it was an MPI problem (it gave the MPI failed to read, and "Parallel Fluent Process could not be started" errors), but when I attempted to run my analysis in serial, I was met with a similar writing error (this time: Access violation).

I have tried running other meshes that I have successfully solved before, and have come across the same issue. I even tried using a different computer and got the same results. As far as I can tell it is some type of core problem possibly related to running 64bit Win7 (both computers had that).

Has anyone else experienced this problem? Does anyone have any suggestions on how to fix it?

Cypher August 30, 2011 17:11

I have now attempted to fix this on multiple computers, using multiple meshes (some from ages ago) that used to work fine, and by rolling back Windows updates to see if that will work. So far, nada.

I did, however, learn two important things.

1) One can get around the save problem by opening Fluent from Workbench and saving the project. However, exporting the Case file results in the same faults as before.

2) The problem seems to be localized to the Cell Zone Conditions and Boundary Conditions screens. Even then, one can input new values, and change boundary assignments with no problem. The only time it hangs up is if one attempts to rename a boundary, or cell zone (i.e. "undefined-region003" --> "external wall").

So whatever this write problem is, it seems to have something to do with changing the Fluent defined names for the cells.

In the end this problem has gone from crippling to niggling. Still I would like to hear if anyone else has experienced something similar. As I've mentioned previously, this never used to crop up before, and it now has been reliably documented in four unrelated computers. I'm trying to nail down exactly what could have changed, but so far have had no luck.

All times are GMT -4. The time now is 15:23.