CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   Hardware (https://www.cfd-online.com/Forums/hardware/)
-   -   Segmentation error in OpenFOAM after RAM upgrade (https://www.cfd-online.com/Forums/hardware/122695-segmentation-error-openfoam-after-ram-upgrade.html)

Man Yue August 26, 2013 03:36

Segmentation error in OpenFOAM after RAM upgrade
 
I am using OpenFOAM 1.7.0 on a notebook. The notebook has originally 2GB of RAM. I upgrade the notebook by adding another 8GB RAM into the notebook. After adding, I run decomposePar. After running decomposePar(i.e. I see the end for decomposePar), the computer shows Segmentation error as follows:

#0 Foam::error::printStack(Foam::Ostream&) in "/opt/openfoam170/lib/linux64GccDPOpt/libOpenFOAM.so"
#1 Foam::sigSegv::sigSegvHandler(int) in "/opt/openfoam170/lib/linux64GccDPOpt/libOpenFOAM.so"
#2 in "/lib/libc.so.6"
#3 cfree in "/lib/libc.so.6"
#4 Foam::polyMesh::~polyMesh() in "/opt/openfoam170/lib/linux64GccDPOpt/libOpenFOAM.so"
#5
in "/opt/openfoam170/applications/bin/linux64GccDPOpt/decomposePar"
#6 __libc_start_main in "/lib/libc.so.6"
#7
in "/opt/openfoam170/applications/bin/linux64GccDPOpt/decomposePar"
Segmentation fault

Why is it and how should it be solved? The notebook and linux itself has no difficulty in detecting the RAM (the linux system shows 9.7GiB).

wyldckat September 14, 2013 13:25

Greetings Man Yue,

I'm a bit late to answer, but it's possible that either the RAM has issues or misconfigured in the motherboard's BIOS.

As for making sure the RAM is OK, you can use Google's stressapptest program, as I for example mention here: http://www.cfd-online.com/Forums/ope...tml#post404995 post #5

Best regards,
Bruno


All times are GMT -4. The time now is 19:12.