CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Main CFD Forum (
-   -   Why I cant use both CFD program at the same time? (

brksnn February 1, 2013 10:05

Why I cant use both CFD program at the same time?
3 Attachment(s)
Hello guys,

I have a interesting problem. Firstly, I am working with ANSYS Fluent 14.5 x64. Secondly, I want to install CFD++ and MIME (solver and mesher from METACOMP).

After installing them, ANSYS keeps working properly but it occurs licence problem. When I try to open "SERVER ANSLIC_ADMIN Utility", I get a problem about TK_LIBRARY and TCL_LIBRARY. These libraries are related to Environment Variables (I dont know what they are). I found the solution from google, the library locations changes after installing another METACOMP CFD programs.

You can find where Environment Variables are from the first picture and I changed them from METACOMP locations to ANSYS locations back to solve the problem.

After changing to locations with Edit button, I got another problem about tcl programming or some dll missing in the second picture. ANSYS still working, but licence fails again. When I try to open SERVER ANSLIC_ADMIN Utilitu, I get this problem.

So, what I have done to overcome these problems.

Firstly, I reinstall the ANSYS without uninstall, I got the same error on picture 2.

Secondly, I uninstalled the ANSYS. Then I tried to open SERVER Utility and it opens. After that, I installed the ANSYS back, I got the same error on picture 2.

Thirdly, after I uninstalled the CFD++ and MIME, I got the same error. Then I uninstalled ANSYS, too and I also deleted the TCL_LIBRARY and TK_LIBRARY from environment variables. After that, I installed ANSYS, finally I works.

After installations, I checked the TCL_LIBRARY and TK_LIBRARY, they didn't seem on the panel, but SERVER ANSLIC_ADMIN Utility worked properly.

Fourthly, I installed the CFD++ and MIME again, TCL_LIBRARY and TK_LIBRARY began to seem on the panel and their locations are placed from METACOMP. After trying to opening ANSYS, I got the first error. I know how I can overcome it. I deleted the libraries from panel, and SERVER ANSLIC_ADMIN Utility opens properly.

However, I got another problem about CFD++ and MIME. In this situation, MIME occurs TCL library problem.

How can anybody use more than one CFD problem at the same time? I know this problem is about Win7. One of my friend had same situation between CFD++ and NASTRAN. He told me there is not a problem like this on Win XP.

Now, What should I do? Should I make my laptop dual-boot with XP or another Win7.

anyone has an idea? :(

All times are GMT -4. The time now is 22:17.