CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > General Forums > Main CFD Forum

Blastfoam installation problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   September 15, 2021, 10:11
Default Blastfoam installation problem
  #1
New Member
 
Pieter-Jan Hochepied
Join Date: Sep 2021
Posts: 1
Rep Power: 0
phochepi is on a distinguished road
Hello everyone

For my thesis at the university of Ghent. I need to work with the blastfoam software. I am trying to download the software but I keep having the same problem over and over again. Can someone help me with this problem and give me the solution? You can find the problem in the screenshots below. The problem occurs when I run the /.Allwmake command.

Thanks a lot

Pieter-Jan Hochepied
Attached Images
File Type: jpg 2021-09-15 (1).jpg (188.0 KB, 10 views)
File Type: jpg 2021-09-15 (2).jpg (198.6 KB, 4 views)
File Type: jpg 2021-09-15 (3).jpg (166.8 KB, 5 views)
File Type: jpg 2021-09-15 (4).jpg (159.1 KB, 7 views)
phochepi is offline   Reply With Quote

Old   May 13, 2022, 09:14
Default
  #2
New Member
 
Join Date: Aug 2015
Posts: 3
Rep Power: 8
tilgnek is on a distinguished road
Hello everyone,


I am facing the exact same problem. Cannot compile blastfoam after exactly following the steps listed in the blastfoam user's guide. I tried on Ubuntu LTS first under Windows 10, also under Windows 11 and now on a native Ubuntu installation. Always get the same error as to be seen in the pictures of the first post. OpenFOAM itself it running without any issues. I am desperate! Please help!
I don't understand the error message
-> "lookupTables/lookupTable2D/lookupTable2D.C:648:13: error: cannot convert ‘Foam::ITstream’ to ‘const Foam::word&’" and a whole host of other similar ones.


Kevin


Last edited by tilgnek; May 13, 2022 at 09:31. Reason: Attaching pic
tilgnek is offline   Reply With Quote

Old   May 13, 2022, 09:46
Default
  #3
New Member
 
Join Date: Aug 2015
Posts: 3
Rep Power: 8
tilgnek is on a distinguished road
Here's a picture. Can anyone tell me what the error messages stand for and/or what can be done?
Thanks a lot in advance
Attached Images
File Type: jpg error1.jpg (59.0 KB, 5 views)
tilgnek is offline   Reply With Quote

Old   May 14, 2022, 17:32
Default
  #4
New Member
 
Join Date: Aug 2015
Posts: 3
Rep Power: 8
tilgnek is on a distinguished road
Heya folks,

I solved the "riddle" ... to my embarrassment, I have to admit I was using OpenFOAMv2112 when trying to compile blastfoam. I wasn't really aware of the differences between openfoam.org and openfoam.com. But of course, in the user's guide, it is stated that OpenFOAMv9 needs to be used in order to compile blastfoam. I was simply assuming I needed the latest version of openfoam to be installed.
tilgnek is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[swak4Foam] [OpenFOAM plus] [v1612+] swak4Foam installation problem in Windows (Allwmake) LThomes OpenFOAM Community Contributions 7 October 6, 2020 13:36
[OpenFOAM.org] Installation problem for paraView 4.1 to go with OpenFOAM-2.4.0-MNF deepbandivadekar OpenFOAM Installation 2 October 25, 2017 08:45
[foam-extend.org] foam-extend-4.0 openSUSE Leap 42.1 Installation Problem icab OpenFOAM Installation 5 April 8, 2017 07:09
Installation problem - calling blockMesh - libblockMesh.so aylalisa OpenFOAM Installation 5 November 28, 2012 09:55
ParaView installation problem on Suse 11.4 victorz OpenFOAM Installation 4 February 6, 2012 17:26


All times are GMT -4. The time now is 01:22.