CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Main CFD Forum (
-   -   error open udf library (

adjie_mesin06 October 26, 2010 00:11

error open udf library
i have a big problem in using compiled UDF. interpreted UDF is working fine, but when i use same code with compiled UDf it gives me following error message.

Opening library "libudf"... Error: open_udf_library: The system cannot find the file specified.

the log file in 'libudf/ntx86/2ddp' shows following:

'cl' is not recognized as an internal or external command, operable program or batch file. NMAKE : U1077: 'cl' : return code '0x1' Stop.

i have installed fluent 6.3.26 and then dev C++ and microsoft visual C++ enterprise 2005, but it still doesn't work.

any help in this regard will be appreciated.

adjie_mesin06 October 27, 2010 01:49

open library 1
Go to 'Control Panel' -> 'Performance and Maintenance' -> 'System' -> 'Advanced' Tab -> 'Environment Variables'

Create environment variables and enter values as follow:

include = C:\Program Files\Microsoft Visual Studio 8\VC\atl\include;C:\Program Files\Microsoft Visual Studio 8\VC\mfc\include;C:\Program Files\Microsoft Visual Studio 8\VC\include

lib = C:\Program Files\Microsoft Visual Studio 8\VC\mfc\lib;C:\Program Files\Microsoft Visual Studio 8\VC\lib

MSDevDir = C:\Program Files\Microsoft Visual Studio 8\Common\MSDev98

Path = C:\Program Files\Microsoft Visual Studio 8\Common7\Tools\WinNT;C:\Program Files\Microsoft Visual Studio 8\Common7\MSDev98\Bin;C:\Program Files\Microsoft Visual Studio 8\Common7\Tools;C:\Program Files\Microsoft Visual Studio 8\VC\bin;c:\\ntbin\ntx86

When I tried to run cl.exe from the command line, the error message I get is "Application unable to start, mspdb80.dll was not found".
vs2005 c:\program files\microsoft visual studio 8\
psdk c:\program files\microsoft platform sdk\

First, go to vs2005 install path c:\program files\microsoft visual studio 8\vc, run vcvarsall.bat to set environment variable; then c:\program files\microsoft platform sdk\, run setenv command: eg: setenv /SRV32 /DEBUG.

I use it to make the program work properly.

All times are GMT -4. The time now is 05:32.