CFD Online Discussion Forums

CFD Online Discussion Forums (
-   Mesh Generation & Pre-Processing (
-   -   Negative determinant in a multiblock o-mesh (

Cosimo March 18, 2013 13:34

Negative determinant in a multiblock o-mesh
Hi everybody,
I am trying to create a multiblock mesh from a STEP geometry file (created by Autodesk Inventor CAD), describing a first stage turbine blade by means of an O-mesh. But I am having problems with the refinement in the boundary layer: when I am trying to reach the required level of y+, I have negative determinant for the element at the wall (blade surfaces, hub and casing). I used a topology tolerance equal to 1 to avoid problems with the CAD geometry. I moved to low triangulation tolerance, tried with the smoothing (orthogonality method), and also projected to bspline, but I have just slight improvements and some elements still present negative values of the determinant. Can you give me some suggestions, please?
Thank you


Cosimo March 18, 2013 13:58

I also saved the geometry file, after having reduced the order of magnitude of the triangulation tolerance, and read it back, but the problem still persists (although the number of elements with negative determinant has decreased).

PSYMN March 18, 2013 15:31

Have you looked at where the elements are (display the histogram and then click on the column for the poorest quality elements)?

If the problem elements are actually near a curve, try setting projection limit (under hexa settings) to something smaller than your smallest mesh size (like 0.1 if you had size 1 mesh). This option helps when the curves are not exactly where they should be on the surface. it interpolates by that distance from the curve instead of projecting the next node to the surface and possibly wrecking the mesh.

Cosimo March 19, 2013 06:13

Yes, the problematic element are close to the wall surfaces. I also tried to set the projection limit to low values, but I still find negative determinants.

PSYMN March 19, 2013 09:42

What is the element size near the walls? Not the boundary layer direction, but the other direction along the surface. Set the projection limit to a larger number but don't exceed that size.

If this is not the solution, you will need to post pics or something so we can get a better idea of what is wrong.

All times are GMT -4. The time now is 18:51.