CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > NUMECA

Singular Line in Outlet Bulb (AutoGrid)

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 22, 2020, 15:33
Default Singular Line in Outlet Bulb (AutoGrid)
  #1
Member
 
Ko Shine
Join Date: May 2018
Posts: 33
Rep Power: 6
Ko_Shine is on a distinguished road
Hi,

To simulate a complete wind turbine model in FINE/Turbo, I've meshed rotor and tower separately in AutoGrid and connected them in IGG. The rotor mesh was created using Row Wizard but the tower mesh was created in Expert mode. For the tower mesh, I needed to activate singular line option in the outlet bulb control. Otherwise, I got loads of negative cells in the outlet bulb. There was nothing wrong with that. The mesh was totally fine and the quality was good. There was no problem with the simulation either.

Now the problem is - I need to do the similar run in ANSYS CFX using the exact same mesh for the direct comparison. I exported the mesh in FLUENT (.msh) format but I can't export the tower mesh as it includes singular line. I tried .cgns format but the singular line is causing problem later on. Is there a way to avoid singular line in a case where the butterfly outlet bulb is not working?

Thank you in advance.
Ko_Shine is offline   Reply With Quote

Old   February 25, 2021, 05:50
Default Try setting the patches as Solid
  #2
New Member
 
Rose buda
Join Date: Jan 2017
Posts: 2
Rep Power: 0
victorbicalho is on a distinguished road
Ideally you should use the butterfly topology for bulbs, since it does not produce singular lines.


As a possible (probably not 100% correct) hack when using the singular line, try setting the Singular (SNG) patches as Solid (SOL) or maybe Rotating (ROT). For me it worked for some simulations.
However, I am not sure if this is indeed the best-practice ansatz for SNG patches (degenerated). I could not find it in neither manual (CFX nor Autogrid [see Section "Export->Fluent"]).


If someone else knows more, please let us know!

Last edited by victorbicalho; February 26, 2021 at 12:55.
victorbicalho is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[mesh manipulation] refineMesh Error mohsen.boojari OpenFOAM Meshing & Mesh Conversion 3 March 1, 2018 23:07
[OpenFOAM] Annoying issue of automatic "Rescale to Data Range " with paraFoam/paraview 3.12 keepfit ParaView 60 September 18, 2013 04:23
8x icoFoam speed up with Cufflink CUDA solver library kmooney OpenFOAM Running, Solving & CFD 42 November 6, 2012 12:37
Problems of Duns Codes! Martin J Main CFD Forum 8 August 15, 2003 00:19
error while compiling the USER Sub routine CFD user CFX 3 November 25, 2002 16:16


All times are GMT -4. The time now is 17:00.