CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Bugs

foamExec does not find applications

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By Steiner

Reply
 
LinkBack Thread Tools Display Modes
Old   April 3, 2018, 12:54
Default foamExec does not find applications
  #1
New Member
 
Join Date: Feb 2018
Posts: 2
Rep Power: 0
Steiner is on a distinguished road
Good evening,

I have installed OpenFOAM 2.3.1 on Ubuntu 18.04 and need to use foamExec for some scripts. foamExec however does not find any applications, which are otherwise run just fine when I source the bash-file of OpenFOAM.

This is what I get:
$HOME/OpenFOAM/OpenFOAM-2.3.1/bin/foamExec simpleFoam
/home/tobias/OpenFOAM/OpenFOAM-2.3.1/bin/foamExec: 145: exec: simpleFoam: not found

Does anyone have an idea where I could start looking why it doesn't work?

Best regards and thanks in advance
Steiner is offline   Reply With Quote

Old   April 8, 2018, 14:48
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 10,209
Blog Entries: 39
Rep Power: 113
wyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of light
Quick question: Why are you already trying to use Ubuntu 18.04, when it's still in beta? Because it is somewhat possible that this is a bug in Ubuntu 18.04...
__________________
wyldckat is offline   Reply With Quote

Old   April 12, 2018, 09:37
Default
  #3
New Member
 
Join Date: Feb 2018
Posts: 2
Rep Power: 0
Steiner is on a distinguished road
I could not get older versions of Ubuntu to work on my laptop.

But I found the issue in the meantime: export WM_COMPILER was not set correctly in OpenFOAMs bashrc. Once I set it to the Compiler I used, foamExec found all the applications.
wyldckat likes this.
Steiner is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coupling with MATLAB via Java, getting the message: "error: cannot find symbol" Dry Patrick STAR-CCM+ 2 March 29, 2018 17:53
/usr/bin/ld: cannot find -llagrangianTurbulence /usr/bin/ld: cannot find -lfluidTherm Luiggito OpenFOAM Programming & Development 9 May 2, 2016 00:54
[swak4Foam] swak4Foam compilation can't find -lOpenFOAM BobR OpenFOAM Community Contributions 4 August 10, 2015 14:49
Error while compiling FoamX related applications geoffjay OpenFOAM Installation 2 May 7, 2008 19:43
Errors running allwmake in OpenFOAM141dev with WM_COMPILE_OPTION%3ddebug unoder OpenFOAM Installation 11 January 30, 2008 21:30


All times are GMT -4. The time now is 23:09.