CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   Bug in reconstructPar (

david January 9, 2009 08:14

Hi everybody I found a bug
Hi everybody

I found a bug in the reconstruction of decomposed cases with moving (not deforming) meshes. The new positions of the mesh points are reconstructed correctly if reconstructPar is used without any optional parameters. When the parameters -time or -latestTime are used, the points are not being reconstructed. The problem occurs with OpenFOAM-1.4.1 and 1.5.


see also:

mattijs January 12, 2009 07:40

Thanks. Attached a fix. Could
Thanks. Attached a fix. Could you let us know whether it works in general and I'll push it into 1.5.x. reconstructPar.C

david January 12, 2009 11:52

Hi Mattijs The fix is worki
Hi Mattijs

The fix is working. Thanks a lot.


feymark April 22, 2009 04:51

Hi everyone!

I'm having problem using reconstructPar -latestTime on a moving mesh. The problem is that the polyMesh-directory is not reconstructed. reconstructPar -time TIME works aslong as I don't use the latest time as TIME. I have tried the latest version of reconstructPar from the svn and also the code Mattijs posted here, it did not work.


mattijs April 23, 2009 13:35

Hi Feymark,

I've pushed a change to 1.5.x which worked on my testcase. Could you let me know if there are any problems with it?



feymark April 27, 2009 07:33

It works, thanks a lot!


feymark April 27, 2009 09:50


I have another problem regarding but decomposePar this time. When I try to run decomposePar the polyMesh-dir isn't decomposed.

Best regards,

feymark April 27, 2009 10:02

I should add that I have, before doing reconstructPar and removing the processor*-folders, 2 different polyMesh-folders under each processor*/-folder. After performing decomposePar the polyMesh in processor*/constant/ is there but not the one in processor*/TIME.


mattijs April 28, 2009 04:44

Does it work with -time? (so directly point at the time-with-polyMesh)

feymark April 28, 2009 05:50

reconstructPar works perfectly fine now. This is a problem with decomposePar and -time is not a valid option there. The polyMesh-folder that is suppose to be in the processor*/TIME-folder is not there after decomposing, only the polyMesh in processor*/constant.


mattijs May 26, 2009 12:11

Hi Feymark,

I pushed a few small changes into 1.5.x which should fix the problem for decomposing cases with meshes in time directories. If the original mesh (at the specified time) originates from anything other than 'constant' it will write the mesh to the time directory. E.g. original case has
- full mesh in constant
- polyMesh/points in 0.3
and current time is 0.5 it will create a full mesh in processor*/0.5/polyMesh and not create a constant folder.

Thanks for reporting.

All times are GMT -4. The time now is 08:50.