CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   Problem compiling OF15x from git sources (

lhcamilo November 27, 2008 09:03

I have used the command gi
I have used the command

git clone

to get the patched new patched version of OF, so to try out the fixes done on snappyHexMesh. The clone git://... command times out for me.

In any case, the file download into a newly made ~/OpenFOAM/ directory

I then have to uncomment $/etc/bashrc line 36 in order to make ./Allwmake work. The line reads


Once I do that I do all that I go to the OpenFOAM-1.5.x directory and run ./Allwmake, it runs for a while but returns with an error

I am uploading the a log file of my second compile attempt.

I am posting a rapidshare link with with THE LOG FILE. It is 200KB big and the native uploader won't have it.

also, a quick question, does the git pull command need to have anything added to it? Sorry for this, I am rather new to GIT.

anyway thanks for your time, hope to hear a reply soon.



olesen November 27, 2008 09:41

I generally find the following
I generally find the following easiest:

1) Create an empty git repository
git init

2) add in a remote
git remote add <name> <url>

git remote add repo

3) list all the available branches:
git branch -a -l

4) fetch from remote:
git fetch repo

5) merge in the upstream updates into your own branch (as desired):

git merge repo/master

If you don't want to merge in the updates from the repo, you can just see what has changed first:

git log --stat --no-merges repo/master ^HEAD

And then either merge all of the changes, merge up to a particular commit, or cherry pick your way through as suits you.

There are a few git tutorials about ... take a read.

lhcamilo November 28, 2008 03:36

thanks for the tip Mark, I did
thanks for the tip Mark, I did look at a tutorials, but since I am new to git I thought I was doing something wrong. So I followed the method that you proposed above (again thanks) and left the computer compiling everything over night

unfortunately this morning the compiling returned the same error as before.Which leads me to believe that the problem is not with the git but it may in the source packages downloaded or with my computer but I find that unlikely since I have compiled openfoam before on the same box without any errors.
So long story short,I am still vary much in the dark about why ti won't compile. If anyone could take a look at the log file I posted above I would really appreciate it.

thanks for the help


olesen November 28, 2008 04:37

I took a look at the log file
I took a look at the log file now and didn't see anything that looked like an error message. Or did you forget to bundle in stderr output as well? (eg, Allwmake > make.log 2>&1 )

Which error are you getting?

lhcamilo November 28, 2008 06:15

I apologize for the inconvenie
I apologize for the inconvenience, I tried to compile again and noticed that my log file was a few (hundred) lines short, this new log file should be more complete


thanks for taking your time to help me out

olesen November 28, 2008 07:12

After paring down your log fil
After paring down your log file, there were only two places that showed errors. I don't know what the first linker error/warning means:
> no .eh_frame_hdr table will be created.
so you're on your own there.

The second group of error messages are CMake related. It looks like you might have an older cmake version or something else.

You'll need to isolate where the problem arises (ie, only recompile the affected sections, not all of the sources).

Attached is your log file reduced to the essential bits. It is now small enough to post here: make.log

All times are GMT -4. The time now is 13:25.