CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   OF 15 Misleading information in README about Qt 43x in openSUSE (

alberto July 15, 2008 12:06

In the README file of OpenFOAM
In the README file of OpenFOAM 1.5 there is the following information:

For openSuSE 10.2, 10.3 and 11.0, Qt version 4.3.5 can be downloaded from:

The link actually provides Qt 4.3.5 for these distributions, but its installation represents a regression for OpenSUSE 11.0, which adopted Qt 4.4.0.
The two versions of QT cannot co-exist (I double checked with OpenSUSE developers), and installing the older Qt 4.3.5 is not recommended.


eugene July 15, 2008 12:25

I think you should go back and
I think you should go back and read the first line of the instructions:

"The ParaView 3.3 visualisation package requires that Qt version 4.3.x MUST be installed on the system. Earlier or more recent versions (4.2.x or 4.4.x) will NOT work."

From what I have gathered, this is a ParaView issue and there isn't much you can do about it until they fix the problem.

eugene July 15, 2008 12:40

I think I posted in haste in t
I think I posted in haste in that the focus of your post regards the regression issues under OpenSUSE 11 not the necessity for the particular version.

That said, there is no reason you cannot have different versions of Qt installed, provided you compile and install (QT_DIR) the alternative versions correctly.

mattijs July 15, 2008 12:42

0) Sorry for the problems with
0) Sorry for the problems with QT but this is a paraview/qt problem. Paraview is extremely sensitive to the QT version. We've tried working around it but can't really.

1) I always thought it was possible to have versions co-exist (but maybe not in rpm form). QT installs in /usr/local/Trolltech/Qt-4.XXX) and if you set your path and LD_LIBRARY_PATH to that version it should work.

2) Just came across this in the Paraview mailing list about supporting QT-4.4.XXX

In the root CMakeLists, comment out the Qt version check, then you can
use 4.4

# * * *MESSAGE(SEND_ERROR "Qt ${QTVERSION} not supported. *Please use Qt
4.3 (you may need to clean your dirtied cache).")

> Hi,
> I have downloaded the latest version of paraview from cvs and with great
> disappointment I can not compile it anymore. Last week I used to compile
> it with qt 4.2.1 and everithing was working fine.
> :-(
> Is there a specific reason for the needed upgrade?
> Also disappointing the fact that Qt 4.4 is also unsupported :-(
> Any hints?
> Thank you
> Simone

alberto July 15, 2008 12:49

Dear Eugene, actually I wa
Dear Eugene,

actually I was simply reporting that the suggestion reported in the README is wrong because the applications provided with openSUSE 11.0 were built against Qt 4.4.0, and replacing it with an older version is at least not recommended and not safe.

As a second note, the paraview provided with OpenFOAM third party package works with Qt 4.4.0 (qmake 2.01a) installed on my openSUSE 11.0 64 bit without problems.

If you:

- Convert the case to VTK with foamToVTK
- Launch paraview from the command line
- Open the VTK Eulerian fields from paraView

you can see data and geometry without any problem, and without any need to recompile paraView.

The problem seems to be in the reader. If I launch, for example:

paraView -case cavity

I see the case information in paraView, but no time is available except "zero" in the time selector, and I can't see any geometry/data even selecting the patches.

However I will investigate further and let you know if I find something new.

Thanks and regards,

alberto July 15, 2008 13:02

About the co-existence of two
About the co-existence of two Qt versions, I wrote in a hurry, but I was referring to the RPM's.

If you try to install the RPM's in the suggested repository, you'll change some of the installed packages, and their provider (from the OSS repository to the QT43 one).


torvic July 15, 2008 16:47

Hi ! I have a question rega
Hi !

I have a question regarding Qt.

I have SLED SP1, with Gnome desktop, and I think I have Qt3.

I don't know how to upgrade to the required Qt4, since the provided link is for openSUSE (and KDE ??)

I will thank any comment/hint



santos July 15, 2008 17:06

Hi, Just to let everyone kn

Just to let everyone know that the workaround provided by Mattijs Janssens works fine in openSUSE 11.0 with QT-4.4.

I did the following:

- In CMakeLists.txt comment the line:

# MESSAGE(SEND_ERROR "Qt ${QTVERSION} not supported. Please use Qt 4.3 (you may need to clean your dirtied cache).")

- Installed libqt4-devel package

- Removed '~/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms' directory

- ran 'buildParaView3.3-cvs' to compile Paraview (you get some warnings but it compiles)

- Followed what is said in the README file to compile the PV3FoamReader module:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3FoamReader

Jose Santos

alberto July 15, 2008 17:30

Victor, yes, in openSUSE < 11.
Victor, yes, in openSUSE < 11.0, you can use that repository without problems.


alberto July 15, 2008 17:49

I did some testing on openSUSE
I did some testing on openSUSE 11.0 64 bit, using OpenFOAM 1.5, gcc and paraview provided by the third party binary packages. For those interested,

rpm -qa libqt*



First of all the good news: it is _not_ necessary to recompile paraview on openSUSE 11.0, even if it has Qt 4.4.0. The package provided by OpenCFD works and can show you data if you simply convert the results of your simulation to VTK with:

foamToVTK -case <case_dir>

Now the bad news. The reader doesn't work properly, so if you try to open a case with:

paraFoam -case <case_dir>

the case is opened, but no data can be shown. I played a bit with the reader, and noticed something weird in how the geometry and time information are passed to paraview.

As a reference I used two cases:

- The cavity case for icoFoam
- A 2D vertical channel case (0.07 x 1m)

If I open the cavity case:

- converting it to VTK with

foamToVTK -case cavity

and the launch paraview directly and open the VTK files, I case see this:

while if you open it using

paraFoam -case cavity

I see this

As you can see the geometry is passed by the reader to paraView as having zero dimensions, and no time is available in the time selector.

Now, I had a suspect: all the dimensions of the cavity have integer part equal to zero. So I used another test case, with one dimension Dx = 0.07 and the other one Dy = 1.

With foamToVTK conversion, it works:

while, as suspected, the reader passes an altered geometry to paraview, with a 0 x 1 "box":

Probably something goes wrong when data are read inside paraview, which should be hardly dependent on Qt though.

I hope this helps,

torvic July 15, 2008 18:05

Thanks a lot Alberto I chec
Thanks a lot Alberto

I checked the repository, and found "SLE_10". I think it can fits to SLED SP1.

I will try with the "4.3.5" version of the files you list in your last post

Lastly, does the upgrade to Qt4 could modify GNOME or YAST ??

Many thanks again Alberto

all the best


alberto July 15, 2008 18:12

Sorry, the pictures were too b
Sorry, the pictures were too big to be uploaded. You can see them here in the order they're cited:

1) foamToVTK1:

2) Reader1:

3) foamToVTK2:

4) Reader2:


alberto July 15, 2008 18:15

Victor, in SLE I think almost
Victor, in SLE I think almost nothing is built against Qt 4.x. I don't think they made such a jump, considering that the reference for that distribution was Qt 3.

As a consequence it should not try to change anything YaST related or GNOME related (which should not be affected by Qt at all).


alberto July 15, 2008 18:17

Btw, this is the _bug_report_
Btw, this is the _bug_report_ discussion board. Please keep questions separated from the bug from now on.


torvic July 15, 2008 18:27

Thanks Alberto Now it's cle
Thanks Alberto

Now it's clear

My sincere apologies for posting in the incorrect thread

all the best


alberto July 15, 2008 19:11

No problem :-) A.
No problem :-)


7islands July 15, 2008 20:49

Hi Alberto, I also tried OF 1
Hi Alberto,
I also tried OF 1.5 installation on openSUSE 11.0 x86_64. In my case, with the system Qt 4.4, at first paraFoam seemd to run fine with all the geometry shown as expected, but when I tried to apply a filter it suddenly crashed. After recompiling ParaView with self-built Qt 4.3.5 (I already had one so have never tried the repository rpms) and PV3FoamReader it seems everything is fine.

About the coexisting of Qt versions, I think adding the Qt 4.3 library/binary paths to OpenFOAM-1.5/etc/apps/paraview3/bashrc should be fine.


alberto July 15, 2008 21:15

Hi Takuya, with what filter
Hi Takuya,

with what filter did you experience the problem? I tried the most common ones (clip, glyphs, ...) and it works OK if I convert to VTK.

Did you try with or without reader?


7islands July 15, 2008 22:26

The crash occurred when I appl
The crash occurred when I applied Extract Block. I always tried with PV3FoamReader, haven't tried foamToVTK at all yet.


alberto July 16, 2008 00:21

Thanks Takuya!. Just anothe
Thanks Takuya!.

Just another note: Recompiling paraview and the reader with Qt 4.4.0 works, but the reader behaves exactly as I reported above in the pictures.


All times are GMT -4. The time now is 08:07.