CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   RhoTurbFoam sonicFoam rhoSonicFoam (

mwibmer August 28, 2008 08:18

Recently I downloaded 1.4.1-de
Recently I downloaded 1.4.1-dev and compiled the code. I tried to run rhoTurbFoam but it exited with the error message (during the first iteration):

--> FOAM FATAL IO ERROR : keyword laplacian((rho*(1|A(U))),p) is undefined in dictionary "/net/capc64/usb1/scratch2/OpenFOAM/q239043-1.4.1-dev/run/rhoTurbFoam/cavity/./s ystem/fvSchemes::laplacianSchemes"

I checked the file system/fvSchemes and found the entry (rho*1|A(U)) (note that the brackets around the expression 1|A(U) are missing). I added these inner brackets in the file system/fvSchemes and the tutorial works.

The same situation for sonicFoam.

On the other side, the tutorial for rhoSonicFoam works fine, despite the brackets around "1|A(U)" in system/fvSchemes are missing.

fra76 August 30, 2008 04:57

You have to provide a scheme f
You have to provide a scheme for "laplacian((rho*(1|A(U))),p)", i.e.:

laplacian((rho*(1|A(U))),p) Gauss linear corrected;

Hope this helps.

mwibmer September 1, 2008 04:28

Hi Francesco, thanks, for t
Hi Francesco,

thanks, for the hint.

The scheme was provided (for sonicFoam, rhoTurbFoam), but the brackets around the expression "1|A(U)" were missing (note that they were missing in the source code, BUT shown in the error message). I added the brackets in the code and the tutorial worked fine.

What I do not understand is
1) why the rhoSonicFoam tutorial works fine, although the brackets around "1|A(U)" are missing.
2) why the error message shows the expression "(1|A(U))" although the sourcecode contains "1|A(U)".

but anyway, it's not a big concern, the tutorials are running....

All times are GMT -4. The time now is 16:04.