CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   Bug or a feature of OF15 (

rafal July 18, 2008 07:04

Description: After changing t
After changing the writeInterval while
case is running OF doesnt write to
disk anymore.


Source file:

Testcase: axiCase.tar.bz2

probably non-specific but I run Gentoo 32

OpenFOAM 1.5

I run the case as it is (attached).
after some time 0.4
I realised that
writeInterval 0.01;

in another terminal i changed
writeInterval 0.1;
and the cases are not written any more.
reverting back to
writeInterval 0.01;
and everything is like it was
(writing every 0.01s)

I run this case twice - the same result.

Thanks in advance

juho July 18, 2008 07:24

I've had similar problems with
I've had similar problems with the twoPhaseEulerFoam - a close relative to the bubbleFoam - in the 1.4.1 version. So it probably isn't a 1.5 related issue. Probably has more to do with the solver.

henry July 19, 2008 14:29

This is a known problem that o
This is a known problem that occurs sometimes but not always when the writeInterval is changed. We will work on it when we have sorted some other pressing issues.


mattijs July 25, 2008 04:39

Could you try this fix and let
Could you try this fix and let us know if it helps? (replace OpenFOAM/db/Time/TimeIO.C with attached version and 'wmake libso OpenFOAM') TimeIO.C

rafal July 25, 2008 05:18

Thanks for this. It works fine
Thanks for this. It works fine now.
I was not really bothered so much by this bug.
It was more like making OF bulletproof.

Another not bothering bug is when in your
path or case have a space (for some strange
reason) ie

/home/OFuser/All cases/case1

with current implementation, the solver interprets it as two arguments. Again not bothering but worth to think for next release.

henry July 25, 2008 05:25

It would be VERY difficult to
It would be VERY difficult to support spaces in the "fileName" and "word" types in the OpenFOAM parser and we do not currently have any plans to attempt it. Have you considered using "_" instead of spaces in your file and directory names?


All times are GMT -4. The time now is 13:43.