CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   Libcso6 version %60GLIBC_234b (

johndeas January 24, 2008 07:29

Hi, I am trying to run Open

I am trying to run OpenFOAM on a Red Hat Entreprise Linux 3, blockMesh and icoFoam run fine on the cavity case, but when I tried to run decomposePar to solve it across several nodes, I get :

decomposePar: /lib/tls/ version `GLIBC_2.3.4' not found (required by /home/flurec/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt/

Has anyone get through this problem ? I haven't had it on Centos 5.1 or Ubuntu 7.10 ...

I also tried to run wmake in the decomposePar directory, but I got errors while it compile /tmp/ccLhuesa.s

johndeas January 24, 2008 07:35

And, if I run decomposePar on
And, if I run decomposePar on another machine, and then launch icoFoam in parallel on the RHEL 3 machine, I get this message :

mca: base: component_find: unable to open paffinity linux: file not found (ignored)

... but the computation runs anyway and output results. Is this a severe default ?

eugene January 24, 2008 09:46

RHEL 3 uses glibc_2.3.2 Upg
RHEL 3 uses glibc_2.3.2

Upgrade your OS it is nearly 5 years old.

The only other alternative is to recompile everything including 3rd party components like gcc from scratch.

gschaider January 24, 2008 10:03

Maybe relinking is sufficient.
Maybe relinking is sufficient. It's faster. But recompiling is safer.

(Problem is, that still RHEL3 seems to be quite popular with clusters)

BTW: Relinking: just remove everything in $FOAM_LIBBIN and $FOAM_APPBIN and Allwmake.

eugene January 24, 2008 11:04

Er, even if you leave everythi
Er, even if you leave everything in $FOAM_LIBBIN and $FOAM_APPBIN, executing Allwmake on a clean distribution will still trigger a complete recompile since the intermediate .o files are stripped out before release.

I think you have recompiled your own distro once to often!

valery_reznic January 24, 2008 11:06

You can use ermine (http://mag
You can use ermine ( or statifier ( to pack program on system where it's work (Ubuntu) and them move packed executable to the "box in question"


nsp82 January 24, 2008 12:02

The same thing happened for me
The same thing happened for me in RHEL 3. I haven't solved the problem yet....

gschaider January 24, 2008 12:33

@Eugene: you're partly right:
@Eugene: you're partly right: I compiled it twice to often.

I pull back my post. Recompiling is ALWAYS the solution. And do it on the system with the lowest version number. Then the binaries should propably be compatible to all the others. (Assuming you only have distros from the same "family". If for instance you have a zoo of RedHat and Ubuntu boxes: Use the one with the lowest glibc)

eugene January 24, 2008 13:01

I really dislike glibc - nothi
I really dislike glibc - nothing technical, just on a personal level.

Re static linking: Since OpenFOAM has more than a hundred executables, linking them all statically would use quite a lot of disk space.

johndeas January 24, 2008 15:13

Thank all for your advices.
Thank all for your advices.

All times are GMT -4. The time now is 16:40.