CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   NEW failure to compile redistributeMeshPar (

pasinari December 27, 2007 13:31

Hi, I experienced a failure

I experienced a failure in recompiling redistributeMeshPar. I already cheched my ./Allwmake, as suggested in a previous message, but this is not the problem.

Compilation of redistributeMeshPar failed due to an unresolved reference.

The failure occured with the following:
Ubuntu 7.10
OF 1.4.1
HP nw8440
gcc version 4.1.3

~/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/parallelProcessing/redistribute MeshPar$ wmake

g++ -m32 -Dlinux -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3 -DNoRepository -ftemplate-depth-40 -I/home/asinari/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/parallelProcessin g/decompositionMethods/decompositionMethods/lnInclude -I/home/asinari/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/parallelProcessin g/decompositionMethods/metis-5.0pre2/libmetis/lnInclude -I/home/asinari/OpenFOAM/OpenFOAM-1.4.1/src/finiteVolume/lnInclude -I/home/asinari/OpenFOAM/OpenFOAM-1.4.1/src/meshTools/lnInclude -I/home/asinari/OpenFOAM/OpenFOAM-1.4.1/src/dynamicMesh/lnInclude -IlnInclude -I. -I/home/asinari/OpenFOAM/OpenFOAM-1.4.1/src/OpenFOAM/lnInclude -fPIC -pthread Make/linuxGccDPOpt/redistributeMeshPar.o -L/home/asinari/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt \
-lfiniteVolume -ldecompositionMethods -lmeshTools -ldynamicMesh -lparMetisDecompositionMethod -lOpenFOAM -ldl -lm -o /home/asinari/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/redistribut eMeshPar
/home/asinari/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt/ undefined reference to `ComputeFillIn2'
/home/asinari/OpenFOAM/OpenFOAM-1.4.1/lib/linuxGccDPOpt/ undefined reference to `METIS_mCPartGraphRecursive2'
collect2: ld returned 1 exit status
make: *** [/home/asinari/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/redistribu teMeshPar] Error 1

It seems that the problem is due to `METIS_mCPartGraphRecursive2' in particular.

Thank you in advance,

mattijs December 28, 2007 11:03

ParMetis seems to come with it
ParMetis seems to come with its own version of the Metis library which overwrites the Metis library from Metis-5.0.

Rebuild the one that comes with the ParMetis. Try something like

cd decompositionMethods/parMetisDecomp

If this doesn't help do the opposite: build the metis-5.0 one last.

pasinari December 31, 2007 05:56

Hi Mattijs, thank you for y
Hi Mattijs,

thank you for your suggestions. Actually I fixed the problem. I was trying to use a different version of gcc. Instead I tried again using the version included in the OF 1.4.1 package and in the architecture folder and it worked.

Thank you,

All times are GMT -4. The time now is 13:43.