CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   Canbt install on Suse 102 (

klausb December 1, 2007 15:11

I am using Suse Linux 10.2 wit
I am using Suse Linux 10.2 with the latest online updates on an Intel Core2

I tried to install OpenFoam according to the instructions found on and encountered two problems:

1. The files ending .gtgz can't be extracted > basically resolved by renaming the file ending to .tgz

2. When I try to extract all the installation files in the suggested file structure $HOME/OpenFoam/linux as described on, the files OpenFOAM-1.4.1.linuxGccDPOpt.gtgz and OpenFOAM-1.4.1.linuxGccSPOpt.gtgz can't be extracted after OpenFOAM-1.4.1.General.gtgz (all these files now ending .tgz so they can be extracted at all) producing an error message "mv: moving „/home/user/OpenFoam/OpenFOAM-1.4.1.linuxGccDPOpt.tgz_FILES/OpenFOAM-1.4.1" to „/home/user/OpenFoam/OpenFOAM-1.4.1" not possible: The directory is not empty

What can I do about it?


santos December 1, 2007 21:05

Hi The steps I usually do t

The steps I usually do to install OpenFOAM are:

mkdir ~/OpenFOAM
mkdir ~/OpenFOAM/linux

copy OpenFOAM-1.4.1* files to OpenFOAM, and gcc, paraview and java to linux

cd ~/OpenFOAM
tar xzf OpenFOAM-1.4.1.General.gtgz
tar xzf OpenFOAM-1.4.1.linuxGccDPOpt.gtgz

cd ~/OpenFOAM/linux
tar xzf gcc*
tar xzf paraview*
tar xzf java*

edit ~/.bashrc and add at the bottom of the file:
. /home/jose/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/bashrc

With this, OpenFOAM is up and running. Please re-try your installation, and tell us if you solved your problem.

Josť Santos

All times are GMT -4. The time now is 13:14.