CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   Compilation fails on suse linux 101 (

su_junwei July 20, 2007 04:34

Dear everyone I am new to o
Dear everyone

I am new to openfoam. I download the openfoam 1.4 and tried to compiled on suse linux 10.1 after fixed it according to the contents on the site
but the following errors arised during the compilation

-lmeshTools /home/sujunwei/OpenFOAM/OpenFOAM-1.4/applications/utilities/mes
h/manipulation/setSet/readline-5.0/platforms/linuxGcc4DPOpt/lib/libreadline.a -L
/usr/lib/termcap -L/usr/lib64/termcap -ltermcap -lOpenFOAM -liberty -ldl -lm -
o /home/sujunwei/OpenFOAM/OpenFOAM-1.4/applications/bin/linuxGcc4DPOpt/setSet
/usr/bin/ld: cannot find -ltermcap
collect2: ld returned 1 exit status
make[3]: *** [/home/sujunwei/OpenFOAM/OpenFOAM-1.4/applications/bin/linuxGcc4DPO
pt/setSet] error 1
make[3]: Leaving directory `/home/sujunwei/OpenFOAM/OpenFOAM-1.4/applications/ut
make[2]: *** [setSet] error 2
make[2]: Leaving directory `/home/sujunwei/OpenFOAM/OpenFOAM-1.4/applications/ut
make[1]: *** [manipulation] error 2
make[1]: Leaving directory `/home/sujunwei/OpenFOAM/OpenFOAM-1.4/applications/ut
make: *** [mesh] error 2

would you give me some suggestion?


msrinath80 July 20, 2007 04:42

Install the termcap package fr
Install the termcap package from an RPM. Go here[1] and choose your platform accordingly and download the relevant RPM file. If there is a termcap-devel package, install it as well. You can install (as root) using the following command 'rpm -Uvh package_name_goes_here.rpm'


NB: The correct thread for this post is on the OpenFOAM -> Installation section.

su_junwei July 20, 2007 04:56

ok Srinath, Thanks now, it w
ok Srinath, Thanks
now, it works well

All times are GMT -4. The time now is 01:54.