CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   foamToTecplot360 error (

PKeller March 5, 2010 04:01

foamToTecplot360 error
1 Attachment(s)
Hi foamers,

like posted in another thread there is a problem with producing tecplot 360 data using foamToTecplot360 utility contained in OF-1.6.x.
Attached is a simple 3D interFoam test case (icem mesh, 1000 cells, initialized with funkySetFields).

Typing foamToTecplot360 produces

Err: (TECZNE112) Wrong number of data values in file 1:
17469 data values for Zone 1 were processed,
9369 data values were expected.
Err: (TECEND112) Wrong number of data values in file 1:
22469 data values for Zone 1 were processed,
9369 data values were expected.
#0 Foam::error:: printStack(Foam::Ostream&)
I have also tried with several other 3D cases and another solver without success. With that solver but 2D axisymmetric case it works fine.

Thanks for any help,

mattijs March 5, 2010 08:26

I ran foamToTecplot360 and converts without errors and it looks ok as well in tec360.

Are you running an uptodate version of 1.6.x? Last changes are from January.



PKeller March 5, 2010 09:48

Hello Mattijs,

I have updated OpenFOAM-1.6.x with git two days ago and compiled it in Opt and Debug mode again.
I just tried it once more with "git pull" and the system told me that it is "already up-to-date".

Thank you,

PKeller March 5, 2010 09:58

Hello Mattijs,

I have forgotten to tell you, that it is necessary to have more than one folder to cause the problem. With converting only one folder the error can't be produced. But I don't want to accuse you that you did not try...

Thanks again,

mattijs March 5, 2010 10:42

Ok. It wasn't closing the faceZones file. I pushed a fix to 1.6.x. Alternatively use the


command line option.

Thanks for reporting,


PKeller March 5, 2010 12:02

Hello Mattijs,

thanks a lot again. That should help.


ehsan October 11, 2011 15:17

Dear Foamer,

We recently installed OF v.2 on different PC's. It works fine but only the foamtotecplot360 does not work and not recognized. We tried to recompile it, in file tecio, the runmake is done perfectly but it does not work again. I could compile the make files in the foamToTecplot360 folder. Could any one help me?


wyldckat October 11, 2011 16:38

Greetings Ehsan,

Start reading from post #10 on this thread: The solution should be in that thread, no matter which installation you have made of OpenFOAM :)

Best regards and good luck!

All times are GMT -4. The time now is 20:40.