CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   ParaView Subwindow Crash (

Emre Turkoz January 22, 2011 06:19

ParaView Subwindow Crash
Hello everybody,

I'm pretty new at the linux environment. I use OpenSUSE 11.2, and downladed & installed OpenFOAM 1.7.1

At first, I tried to run the "lid driven cavity" tutorial. I can see the result and it's all correct. But when I open a subwindow - for example if I want to "Edit Color Map", i'm at a dead end. When I try to close that window, paraview also closes. And I get the message: /home/emreturkoz/OpenFOAM/OpenFOAM-1.7.1/bin/paraFoam: line 119: 21569 Segmentation fault paraview --data="$caseFile"

What can I do?

Thank you all for your support.

Emre Turkoz January 22, 2011 07:15

I also get the error:
GLXBadContextTag 170
Extension: 153 (Uknown extension)
Minor opcode: 5 (Unknown request)
Resource id: 0x3e0003

wyldckat January 22, 2011 14:13

Greetings Emre,

I assume you installed the latest OpenFOAM 1.7.1 SuSE/RPM packages released by OpenCFD at, correct?

The problem you are having has already occurred in the past several times (I searched for "Edit Color Map" in the main OpenFOAM forum):
The solution is usually downgrading, upgrading or even disabling the graphic card drivers (disabling usually means switching to VESA drivers). The reason is linked to a bad call to the OpenGL drivers installed for the card, which try to access the graphics card in a very wrong way, or even to a function that isn't implemented.
With luck, ParaView only crashes; but with bad luck, the whole computer crashes and you have to do a cold boot (shutdown the machine completely and turn it back only after a few seconds). With some serious bad luck, you can only turn the computer back on after an hour or two, due to so weird access made to the GPU which leads it to go into a trance... although this usually only happens when programing hardcore CUDA kernels.

Best regards,

Emre Turkoz January 22, 2011 15:33

thank you so much!

I installed the driver of my Nvidia card and now it works neat and nicely!

All times are GMT -4. The time now is 04:29.