CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Bugs (
-   -   Polymesh missing data... (

nicko September 1, 2011 01:46

Polymesh missing data...
1 Attachment(s)
Hey All,
I am a noob. I have installed the latest version of OpenFOAM as per these instructions:
So I am running through Virtual Box.
My problem is that when I run the tutorials I am always getting the error that I am missing an integer or '(' in the mesh points file. I took a look at the file and the nPoints is missing from the top. So I took a look and nFaces is also missing from the faces file.
Here is the error:

incorrect first token, expected <int> or '(', found on line 18 an error

file: /home/nick/OpenFOAM/nick-2.0.1/run/tutorials/incompressible/icoFoam/cavity/constant/polyMesh/points at line 18.

From function operator>>(Istream&, List<T>&)
in file /home/opencfd/OpenFOAM/OpenFOAM-2.0.1/src/OpenFOAM/lnInclude/ListIO.C at line 149.

FOAM exiting

I am hoping that this is something simple that I overlooked. Your comments are appreciated.

wyldckat September 1, 2011 17:08

Greetings Nick and welcome to the forum!

Mmm... this is very odd. Run blockMesh once more and try running icoFoam again.

My deduction is this: the file you posted seems to have been corrupted somehow by some other application or possibly hardware malfunction; but if it were a hardware problem, you would have noticed it by now, since a lot more stuff would be crashing more often.

Therefore, it seems that there is some software that is damaging the proper operation-ability of OpenFOAM. This is why I'm asking you to run those two applications once more on that case, in order to try and replicate the situation.

Best regards,

miguelon February 7, 2012 14:18

polymesh missing data
Dear all,

I must admit I'm quite a noob and have found the same problem as Nicko.

My configuration is the same as him: OpenFOAM running on both Ubuntu 11.10 and on SuSE 11.4 linux, hosted in Windows (XP and 7) native machines through VirtualBox.

What I get when running the cavity tutorial is that the file cavity/polyMesh/points file gets corrupted in line 18, where the lines:

(0 0 0)
(0.005 0 0)
(0.01 0 0)
(0.015 0 0)
(0.02 0 0)
(0.025 0 0)
(0.03 0 0)
(0.035 0 0)
(0.04 0 0)
(0.045 0 0)
(0.05 0 0)
(0.055 0 0)
(0.06 0 0)
(0.065 0 0)
(0.07 0 0)
(0.075 0 0)
(0.08 0 0)
(0.085 0 0)
(0.09 0 0)

are substituted by a series of ^@ characters.

I may go back to the Windows machine and get the right text in order to rebuild the original file, but then it's the faces file the one that gets corrupted again and so on...

My question is that this looks rather related to special character or text codification between Windows and linux through VirtualBox, since the same error appeared under different platforms and linux flavours, doesn't it?

Don't know if this has already been diagnosed and fixed, but Nicko's one has been the only report matching my (short) experience I have found over the Internet.

Thanks to you all in advance.

Best regards,


wyldckat February 7, 2012 15:46

Greetings Miguelon and welcome to the forum!

A few weeks ago it was discovered that there was a weird bug with VirtualBox 4.1.8, which did not occur with 4.1.6. This was reported on OpenFOAM's bug tracker and the solution posted on the comment #932:

Other than this, I haven't been able to trigger this specific bug, where blockMesh is unable to properly save data.

If you can, please also state which language settings you are using on Ubuntu and openSUSE, as well as the amount of RAM allocated to the virtual machines. This way I (or anyone else) can try and recreate the same working environment, in order to try and figure out what really is going on wrong.

By the way, are you running the case inside a shared folder? You know, one of those shared folders between virtual and real machine.

Best regards,

miguelon February 7, 2012 16:48

Thanks, Bruno, for your fast and useful advice.

Concerning my environment(s), I have installed Ubuntu and SuSE in English language (the default option) and have allocated 2048 kB of RAM to the VM.

And I must answer yes to your last question, I run the test cases in a shared folder.

I'll try the suggested solution and let you know.

Thanks again,


miguelon February 8, 2012 19:03

Hi there,

I have uninstalled everything, downgraded to VirtualBox 4.1.6, followed the installation instructions from the start and... I got the same error !!!

However, if I had the caution of copying the tutorials tree on a non-shared folder and running OpenFOAM therein, it worked OK.

Therefore it must be a matter of the way read/write permissions are managed between the host and the guest machine in shared folders.

Thanks for the hint, Bruno.

Kind regards,


miguelon February 8, 2012 19:07

Sorry, I have just realised on my previous posts that I had allocated 2048 MB of RAM to the VM, obviously not 2048 kB.



All times are GMT -4. The time now is 03:58.