CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Community Contributions > OpenFOAM CC Toolkits for Fluid-Structure Interaction

[FSI] Foam-Extend 4.1 Extend Bazaar Allwmake fail compiling on Opensuse Tumblweed

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 18, 2020, 21:47
Question Foam-Extend 4.1 Extend Bazaar Allwmake fail compiling on Opensuse Tumblweed
  #1
Member
 
Sultan Islam
Join Date: Dec 2015
Location: Canada
Posts: 61
Rep Power: 6
EternalSeekerX is on a distinguished road
Hello OpenFOAM CC,


I hope everyone is doing well. So a little background. I am running Opensuse Tumbleweed on a 6 core VM based on an i7 7700HQ. I was able to compile Foam Extend 4.1 using the instructions for building 4.0. It had no errors and runs fine. I wanted to try the FSI and solid tutorials from the bazaar so I attempted to build it using the files given in the extended bazaar folder of the foam-extend4.1 package. It fails after awhile with 2 errors (one for FSI and one for AxialMesh)


I then edited the allwmake file to build each one individually with logs. So here they are:


FSI:
Code:
cc1plus: all warnings being treated as errors
make: *** [centrifugalBodyForce.dep:859: Make/linux64GccDPInt32Opt/centrifugalBodyForce.o] Error 1
Axial Mesh:
Code:
makeAxialMesh.C:52:10: fatal error: Time.H: No such file or directory
   52 | #include "Time.H"
      |          ^~~~~~~~
compilation terminated.
make: *** [makeAxialMesh.dep:365: Make/linux64GccDPInt32Opt/makeAxialMesh.o] Error 1
It seems both of the errors are due to C++ headers or such? I also will attach a zip file containing the logs of FSI, axialmesh and the the full allwmake log from the original allwmake file in the directory.



So does anyone know what the issue could be? I am just trying to get everything setup so I can learn about fsi.
Attached Files
File Type: zip Extend Bazaar Logs.zip (89.1 KB, 0 views)
EternalSeekerX is offline   Reply With Quote

Reply

Tags
build error, extend-bazaar, foam-extend-4.1, fsi

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[foam-extend.org] Docker Container for Foam Extend 4.1 illuminati5288 OpenFOAM Installation 2 May 30, 2020 09:42
[foam-extend.org] Foam-Extend 4.1 Extend Bazaar make error EternalSeekerX OpenFOAM Installation 2 May 15, 2020 21:28
Block coupling three equations using foam extend 4.1 ELwardi OpenFOAM Programming & Development 2 March 19, 2019 10:35
A problem with immersed boundary method running in parallel in foam -extend 4.1 kinakamichibun OpenFOAM Bugs 0 November 8, 2018 05:03
[swak4Foam] undefined symbols in .so libraries when compiling swak4foam 0.4.2 on foam extend 4.1 mAlletto OpenFOAM Community Contributions 3 August 29, 2018 06:02


All times are GMT -4. The time now is 14:30.