CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Community Contributions > OpenFOAM CC Toolkits for Fluid-Structure Interaction

HronTurekFsi does not run with more than 8 cpu's

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   May 28, 2020, 08:26
Default HronTurekFsi does not run with more than 8 cpu's
  #1
New Member
 
Peter Knapen
Join Date: Sep 2009
Posts: 28
Rep Power: 13
peterk is on a distinguished road
Gents,

I have a new computer with AMD 3950X processor (16 cores) and 64 GB memory.
I have installed foam-extend 4.1 from source under Ubuntu 20.04LTS, gcc/g++ version 7

When I run HronTurekFsi with AllrunPar, I can change the decompaseParDict files upto 8 domains for fluid and solid and the anaysis does run.
However when I try more than 8 regions/processors , say 16, I get following messages:Running fluent3DMeshToFoam on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/fluid
Running changeDictionary on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/fluid
Running setSet on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/fluid
Running setsToZones on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/fluid
Running decomposePar on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/fluid
Running fluent3DMeshToFoam on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/solid
Running changeDictionary on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/solid
Running setSet on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/solid
Running setsToZones on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/solid
Running decomposePar on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/solid
changing into fluid directory
creating links
creating processor links
Running icoFsiElasticNonLinULSolidFoam in parallel on /home/pk28831/foam/pk28831-4.1/run/HronTurekFsi2/HronTurekFsi/fluid using 16 processes


and nothing happens anymore




Is there somewhere an environment variable to be set for more than 8 cpu's?
Best regards,
Peter




Setting the variable nCellsInCoarsestLevel to 10 instead of 20 in fvSolution did the job

Last edited by peterk; June 9, 2020 at 10:04. Reason: solved
peterk is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CFDEMcoupling run: two identical runs have different error messages minzhang OpenFOAM Running, Solving & CFD 0 April 24, 2020 13:17
[OpenFOAM.org] paraFoam Fatal Error upon run Gallienus OpenFOAM Installation 2 April 14, 2020 19:23
Cannot run phoenix on linux opensuse 13.1 kde mabal Phoenics 0 June 15, 2014 06:16
[mesh manipulation] Cannot get refineMesh to run in parallel smschnob OpenFOAM Meshing & Mesh Conversion 2 June 3, 2014 11:20
How to run ".def" model with parallel CPUs mohammad CFX 5 January 10, 2011 18:00


All times are GMT -4. The time now is 17:38.