CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM Community Contributions (https://www.cfd-online.com/Forums/openfoam-community-contributions/)
-   -   [ImmersedBoundary] Immersed Boundary on OF-ext-3.1 Installation Problem (https://www.cfd-online.com/Forums/openfoam-community-contributions/157048-immersed-boundary-ext-3-1-installation-problem.html)

utkunun July 18, 2015 12:27

Immersed Boundary on OF-ext-3.1 Installation Problem
 
1 Attachment(s)
Dear All,

I am working on a mac with OS X 10.6.8 (Snow Leopard). My purpose is to install immersed boundary solvers along with OpenFOAM-extend-3.1. In this regard,

1. I managed to install OpenFOAM version 2.1.x as in https://openfoamwiki.net/index.php/I...OpenFOAM_2.1.x and it works fine.

2. Then I installed OpenFOAM extend-3.1 as in https://openfoamwiki.net/index.php/I...oam-extend-3.1 (step 3) and this also finished smoothly.

3. Finally I tried to install immersed boundary solver-as in https://openfoamwiki.net/index.php/E...mersedBoundary, but in step 2.3 ./Allwmake returned errors and compilation was not successful. Specifically, each wmake returned the following error (I attached my log file to this post.):

ld: warning: directory not found for option '-L/Users/userme/foam/foam-extend-3.1/lib/darwinIntel64GccDPOpt/openmpi-macport-mp'

As stated in the error, openmpi-macport-mp does not exist where it's supposed to be.

I think it is related to foam-extend-3.1 being installed by a sparse image mount. In order to check that, I tried to compile foam-extend-3.1 next, which returned multiple errors complaining about disc space; but the openmpi-macport-mp directory was created this time. And when I tried to install immersed boundary solvers, this time the process finished smoothly without errors.

Would you please help on how to tackle this problem?

PS: I am sorry for the post format in advance if it's not suitable as this is my first post on the forum.

wyldckat July 19, 2015 13:36

Greetings utkunun,

Sourceforge.net is currently having problems, so I can't check if foam-extend 3.2 is already officially out or not :(

I haven't updated the wiki page for the "ImmersedBoundary" toolkit essentially for the same reason, i.e. I don't know if foam-extend 3.2 has already been officially released or not as its own repository.

All of this to say that as of foam-extend 3.2, the "ImmersedBoundary" toolkit is already integrated into it.

Either way, you will have to build from source code and after you clone the foam-extend 3.1 repository, you can git checkout the "nextRelease" branch, which has most (if not all) of the files for foam-extend 3.2, by running these commands:
Code:

git checkout nextRelease
Then you can try to proceed with the build instructions.

Beyond this, I don't have access to a Mac, so I have no idea how to build foam-extend from source code in it :(

Best regards,
Bruno

utkunun August 2, 2015 14:46

Hello Bruno

Thank you for your response anyway.

Regards.

wyldckat August 10, 2015 16:39

For future reference, this was followed up here: http://www.cfd-online.com/Forums/ope...-10-6-8-a.html


All times are GMT -4. The time now is 02:23.