CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Community Contributions

[swak4Foam] OF 3.0.0 cluster install problems

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 18, 2016, 12:23
Default OF 3.0.0 cluster install problems
  #1
Member
 
Matt
Join Date: Oct 2012
Posts: 39
Rep Power: 7
fatirishman53 is on a distinguished road
It is completely possible that I am dumb and/or blind, but I can't seem to find a solution to this problem:

I am working on a CentOS 6.2 cluster system that has OpenFOAM-2.3.x and OpenFOAM-3.0.0 installed.

I have sucessfully installed swak4Foam on my personal computer for OpenFOAM-3.0.0.

I have successfully installed swak4Foam for 2.3.x within the cluster system at "$HOME/OpenFOAM/$USER-2.3.x".

However, when following the same procedure within the cluster system at "$HOME/OpenFOAM/$USER-3.0.0", I get the errors within the make.log file attached to this post. (I ensured that I sourced "$WM_PROJECT_INST_DIR/OpenFOAM-3.0.0/etc/bashrc")

I used "openfoam-extend-swak4Foam-dev-master" as the installation source for 3.0.0.

The first thing that catches my eye is "No swak4FoamParsers/foamVersion4swak.H. Generated" followed by a slew of "could not open file * for source file * due to Permission denied". Yet, the permissions are no different that the OpenFOAM-2.3.x installation.

Any help would be appreciated. Thanks.
Attached Files
File Type: txt make.log.txt (151.5 KB, 2 views)
fatirishman53 is offline   Reply With Quote

Old   September 7, 2016, 10:24
Default
  #2
Member
 
Matt
Join Date: Oct 2012
Posts: 39
Rep Power: 7
fatirishman53 is on a distinguished road
As it turns out, our cluster administrator used a pre-compiled version of OpenFOAM for CentOS. In the end, the permissions ended up being more strict, which is why I was getting the premission errors (I know... duh). Also, the shared libraries weren't being written to $USER-$WM_PROJECT_VERSION. The admin ended up temporarily granting me full permissions over the OpenFOAM folder structure and I was able to get the problems sorted out.

I thought I had seen a solution where the shared libraries could be referenced from a global location, but I couldn't re-find it. If anyone knows about this, I would appreciate the information.

Thanks.
fatirishman53 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SAP cluster resource/services not coming online on cluster node 2 Nthar1@yahoo.com Hardware 0 May 9, 2017 05:55
foam-extend 3.1 installation problems: ParaView 4.0.1 RPM won't install KayGhana OpenFOAM Installation 4 March 31, 2017 06:38
Problems to install openfoam-2.4.0 on Ubuntu 16.04.01LTS matheusmonjon OpenFOAM Installation 3 February 25, 2017 15:46
error make SU2 4.0.1 Heathckliff SU2 Installation 2 November 9, 2015 06:48
How to install OpenFoam1.71 on cluster without Root permission? ripperjack OpenFOAM Installation 7 May 7, 2013 16:46


All times are GMT -4. The time now is 13:12.