CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM > OpenFOAM Community Contributions

[waves2Foam] Waves2Foam postProcessing

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   February 3, 2020, 12:40
Default Waves2Foam postProcessing
  #1
New Member
 
Conor Owen
Join Date: Jan 2020
Posts: 2
Rep Power: 0
Cjyowen1 is on a distinguished road
Hello,
I am fairly new to OpenFOAM and waves2Foam and am currently using it for my honors project in university. I am currently using Ubuntu 16.04, OpenFOAM 4.1 and waves2Foam. I am running a case in which I require the surface elevation of my wave tank to be output into the postProcessing folder. When i run the case it completes every step of my Allrun command bar the last step, creating the postProcessing folder, i have searched for this problem (or similar) an am unable to find anything close to this problem.



The following error is what comes up in the log file;

"Create time


Reading g
Processing: regularSpectrum
Processing sub-action: interpolateSurfaceElevation
#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::sigSegv::sigHandler(int) at ??:?
#2 ? in "/lib/x86_64-linux-gnu/libc.so.6"
#3 double Foam::dictionary::lookupOrDefault<double>(Foam::wo rd const&, double const&, bool, bool) const at ??:?
#4 Foam::postProcessingWaves::equidistantTime(Foam::L ist<std::pair<double, int> > const&, Foam::dictionary const&) at ??:?
#5 Foam::interpolateSurfaceElevation::evaluate() at ??:?
#6 main at ??:?
#7 __libc_start_main in "/lib/x86_64-linux-gnu/libc.so.6"
#8 ? at ??:?"



I found a case which output the velocities of the waves in a post processing folder which worked, so i am sure it is something to to with the surface elevation.



Any help would be greatly appreciated as im very new to this,



Conor

Last edited by Cjyowen1; February 3, 2020 at 12:42. Reason: Wrong title
Cjyowen1 is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pressure outlet boundary condition rolando OpenFOAM Running, Solving & CFD 62 September 18, 2017 07:45
DPM udf error haghshenasfard FLUENT 0 April 13, 2016 07:35
[OpenFOAM] Native ParaView Reader Bugs tj22 ParaView 270 January 4, 2016 12:39
Compiling problems with hello worldC fw407 OpenFOAM Installation 21 January 6, 2008 18:38
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 18:51


All times are GMT -4. The time now is 09:07.