CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation on Windows, Mac and other Unsupported Platforms (
-   -   Pre-compiled disk images of version 2.1 for Mac? (

einatlev August 17, 2012 15:49

Pre-compiled disk images of version 2.1 for Mac?
Thank you for all your work on OpenFOAM!
I recently installed the latest 2.1.x version of OpenFOAM on my Linux machine, using the source code from the git repository. I have also installed version 2.0 on my Mac laptop, using the pre-compiled disk images. Both work well. Now I'd like to run the new solver "optentialFreeSurfaceFoam", which was added in v.2.1.x, on my Mac, but I'd like to avoid having to build from scratch source code on the Mac, if possible. Are there any precompiled version 2.1 files out there?

wyldckat August 31, 2012 06:50

This comes a bit late, but for your information:

Originally Posted by qzt (Post 379393)

I just uploaded the disk image (dmg file) of OpenFOAM-2.1.0 compiled on my macbookpro running lion (os 10.7).
Maybe someone having difficulty to compile or want to save some time can just use it.

I think after mounting the disk image, one can try to source the bashrc and run the foamInstallationTest to see if it works on your mac.

einatlev September 8, 2012 17:03

Thanks much.

einatlev September 8, 2012 17:47

I'm running into problems installing the DMG file:
Anything I try to do, I get an error saying that this is a "read-only file system". I tried changing the disk-image name to .sparseimage instead of .dmg, and also to make the disk image writable to all users, but nothing helped. I tried using sudo, no help.
Any ideas??

wyldckat September 9, 2012 03:52

Hi Einat,

:confused: Why do you want to change that image to be read-write? You only need it for getting a working OpenFOAM installation!
Anything else can be written in your personal folders!

Best regards,

einatlev September 9, 2012 10:27

I didn't necessarily want to, but I get an error even when I try to create the "$USER-2.1.0" folder that the installation instructions call for. And I tried cleaning and re-building, b/c the instructions said it was a good idea, and I kept getting errors that it was read-only system...

wyldckat September 9, 2012 11:50

It's simple (assuming nothing is mounted):
  1. Mount the read-only image at "/Volumes/OpenFOAM-v2.1" with case-sensitivity turned on (if that's a choice).
  2. Run these commands:

    cd ~
    mkdir OpenFOAM
    cd OpenFOAM
    ln -s /Volumes/OpenFOAM-v2.1/OpenFOAM-2.1.0 OpenFOAM-2.1.0
    ln -s /Volumes/OpenFOAM-v2.1/ThirdParty-2.1.0 ThirdParty-2.1.0

    It will create symbolic links to the mounted image, only linking the relevant folders.
  3. Source OpenFOAM's "bashrc":

    source ~/OpenFOAM-2.1.0/etc/bashrc
  4. Try running icoFoam:

    icoFoam -help
    If it works, you're ready to go!

einatlev September 9, 2012 12:02

Got it. So to run a tutorial, I first need to copy it into a read-write folder of my own, and then run it? I tried that with icoFoam's cavity example and it seemed to work.

wyldckat September 9, 2012 12:34

Yes, that's the idea. Actually, following the steps I outlined, you should be able to run the commands listed shown in the section Getting Started from

The same goes for solvers and libraries you may want to modify. For creating a modified solver, here is a good tutorial for it:

einatlev September 9, 2012 19:23

Awesome! thanks so much!

morourke October 12, 2012 09:02

Problems with parafoam starting

I followed the instructions and everything went fine until I went to run paraFoam. I got the following message. Any help appreciated.

dhcp-892b949a:~ malachyorourke$ paraFoam

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

dhcp-892b949a:~ malachyorourke$ cd cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
-bash: cd: cd: No such file or directory
dhcp-892b949a:~ malachyorourke$ paraFoam

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

dhcp-892b949a:~ malachyorourke$ cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers
dhcp-892b949a:PV3Readers malachyorourke$ ./Allwclean
+ wclean libso vtkPV3Readers
wclean vtkPV3Readers
+ PV3blockMeshReader/Allwclean
+ rm -f '/Users/malachyorourke/OpenFOAM/OpenFOAM-2.1.0/platforms/darwinIntel64Gcc46DPOpt/lib/libPV3blockMeshReader*'
+ rm -rf PV3blockMeshReader/Make
+ wclean libso vtkPV3blockMesh
wclean vtkPV3blockMesh
+ PV3FoamReader/Allwclean
+ rm -f '/Users/malachyorourke/OpenFOAM/OpenFOAM-2.1.0/platforms/darwinIntel64Gcc46DPOpt/lib/libPV3FoamReader*'
+ rm -rf PV3FoamReader/Make
+ wclean libso vtkPV3Foam
wclean vtkPV3Foam
dhcp-892b949a:PV3Readers malachyorourke$ ./Allwmake
+ '[' -d /Users/malachyorourke/OpenFOAM/ThirdParty-2.1.0/platforms/darwinIntel64Gcc46/paraview-3.12.0 -a -r /Users/malachyorourke/OpenFOAM/ThirdParty-2.1.0/platforms/darwinIntel64Gcc46/paraview-3.12.0 ']'
dhcp-892b949a:PV3Readers malachyorourke$


wyldckat October 12, 2012 15:48

Greetings Malachy,

Read this: - section "3 Installing and using ParaView"

Best regards,

All times are GMT -4. The time now is 12:02.