CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation on Windows, Mac and other Unsupported Platforms (
-   -   2.1 installation on Mountain Lion help please! (

PeteH April 22, 2013 12:31

2.1 installation on Mountain Lion help please!
Hi all,

I have been in the background on this forum a lot. Mostly reviewing all the problems people have had installing openFOAM. Well I finally got the courage to have a go and install it myself. I used the wiki install guide found here

The installation process went pretty smoothly, or so I thought... When I go to run the cavity tutorial I get an error when running the paraFoam command.


Petes-MacBook-Pro-2:cavity Pete$ paraFoam

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

I I cd'd to that folder and performed the Allwclean and Allwmake but get the same error when I try to run paraFoam again. Any ideas?

I tried to build ParaView from the Thirdparty2.1.1 folder and got this error:

*** Error: cannot find qmake either at $QMAKE_PATH or in current $PATH
So I tried to build the Qt in the Thirdparty2.1.1 folder and recieved this error:

Petes-MacBook-Pro-2:ThirdParty-2.1.1 Pete$ ./makeQt
Starting build: Qt-4.7.3
./makeQt: line 107: cd: /Users/Pete/OpenFOAM/ThirdParty-2.1.1/qt-everywhere-opensource-src-4.7.3: No such file or directory
Error building: Qt-4.7.3

I'm assuming this has something to do with it.

Any help would be greatly appreciated!

wyldckat April 22, 2013 14:59

Greetings Peter and welcome to the forum!

Did you see the chapter 3 on the instructions? Well, if they seemed to confusing, please check if the current description is better now:

In essence, if you follow the description on that chapter, you don't need to build ParaView from source code! ;)

Best regards,

PS: thanks for posting in the right forum. Next time you can use the triangle sign on the lower left corner of a post, to report a misplaced post. Or contact one of the forum admins/moderators, as listed in the main forum, at the end of the list of forums! ;)

PeteH April 22, 2013 15:31

Thanks for the quick reply!

That got it working. I had trouble understanding if I needed a .alias file but I just put the aliases in my bashrc and that got it working.

I was able to run the blockMesh and icoFoam before but now I'm having another problem.
When trying to run blockMesh I get:

dyld: Library not loaded: /Users/Pete/OpenFOAM/ThirdParty-2.1.1/platforms/darwinIntel64Gcc46/openmpi-1.5.3/lib/libmpi.1.dylib
  Referenced from: /Users/Pete/OpenFOAM/OpenFOAM-2.1.1/platforms/darwinIntel64Gcc46DPOpt/lib/openmpi-1.5.3/libPstream.dylib
  Reason: image not found
Trace/BPT trap: 5

I went to the first directory and noticed that libPstream.dylib was there but the lib folder was not.

but it was working before???

Did I change something/recompile something that could make this happen?

Thanks for all your help!


wyldckat April 22, 2013 15:52

Hi Pete,

How did you do this step: - when you were following the instructions for the first time?

Best regards,

PeteH April 23, 2013 10:23

Hi Bruno,

I did that step incorrectly. I performed it again and everything seems to be working properly now! This is my first, real, in depth try at the terminal prompt so it's been a little shaky. Thanks for all the help! I'm sure you will be seeing me in the meshing section shortly!

Thanks again,

All times are GMT -4. The time now is 11:21.