CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation on Windows, Mac and other Unsupported Platforms (
-   -   paraFoam Error on Mac 10.8.2 (mountain lion) (

hkmamike May 30, 2013 04:45

paraFoam Error on Mac 10.8.2 (mountain lion)
I have a working recompiled OpenFoam on my OSX 10.8.2 (I followed the instructions

Then I downloaded the paraview4.0.0 and placed it into my /Applications folder

I tried running the cavity test run with the commands in the OpenFoam/OpenFOAM-2.2.0/tutorials/incompressible/icoFoam/cavity directory:


blockMesh (produced initial value input files)
icoFoam (produced text results)

And this last code is where I have the problem. This produced the error message:


FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

I am aware that the same exact error message has been discussed, but as far as I know, no solution has been provided for mac users.

When I open up the directory:

and open the Allwmake executable with a text editor, I found the following content:


cd ${0%/*} || exit 1    # run from this directory
#set -x

if [ -d "$ParaView_DIR" -a -r "$ParaView_DIR" ]
    [ -n "$PV_PLUGIN_PATH" ] || {
        echo "$0 : PV_PLUGIN_PATH not valid - it is unset"
        exit 1

    # ensure CMake gets the correct C++ compiler
    [ -n "$WM_CXX" ] && export CXX="$WM_CXX"

    wmake libso vtkPV3Readers
    echo "ERROR: ParaView not found in $ParaView_DIR"

# ----------------------------------------------------------------- end-of-file


so apparently the error was produced by the false conditionals involving $ParaView_DIR and $PV_PLUGIN_PATH.

When I echoed these two variables in the terminal, I found them to be empty.

Now, there is one source on this forum that I found that is relevant (post #8):

However, when I searched for the mac equivalent folder:


no paraview-3.12 or any version variation can be found.

The closest thing that I was able to find was:


Now my question is: How do I fix this problem and run paraFoam on OSX? do I simply need the correct paths for the two variables listed? if so, what are they?

Please advise.

wyldckat June 8, 2013 17:14

Greetings Mike and welcome to the forum!

Check these instructions: - namely section "Installing and using ParaView"

Best regards,

mpage September 9, 2013 21:23

FATAL ERROR: ParaView reader module libraries do not exist
I tried the same link but eventually ended up installing the binary paraView 4.0 app

My .alias file now looks like:
alias paraview="/Applications/"
alias paraView="/Applications/"
alias parax="touch case.foam && paraview --data=case.foam &"
alias paraFoam="paraFoam -builtin"

paraview will launch just fine but if i try to run paraview from paraFOAM I get the above message about missing pv3reader libraries

Are these libs built at the same time as paraview?

Since I have the paraview 4.0 in my Applications folder and being pointed to by the .alias file, how can I jump ahead in the paraview build process and just do the pv3reader libraries? or can I?


wyldckat September 10, 2013 16:41

Greetings Mike and welcome to the forum!

There is no building/compiling involved for ParaView on Mac OS X. You only need to install it, from the package provided at

As for having this working properly, does is work if you run:

instead of paraFoam?

If not, then what happens if you run the following two commands?

alias parax
alias paraFoam

Best regards,

mpage September 10, 2013 16:56

testing parax
/Users/mpage/OpenFOAM/mpage-2.2.x/run/tutorials/incompressible/icoFoam/cavity $ > parax
[1] 2218
/Users/mpage/OpenFOAM/mpage-2.2.x/run/tutorials/incompressible/icoFoam/cavity $ > dyld: DYLD_ environment variables being ignored because main executable (/bin/ps) is setuid or setgid

[1]+ Done touch case.foam && /Applications/ --data=case.foam
/Users/mpage/OpenFOAM/mpage-2.2.x/run/tutorials/incompressible/icoFoam/cavity $ > alias parax
alias parax='touch case.foam && paraview --data=case.foam &'
/Users/mpage/OpenFOAM/mpage-2.2.x/run/tutorials/incompressible/icoFoam/cavity $ > alias paraFoam
alias paraFoam='paraFoam -builtin'
/Users/mpage/OpenFOAM/mpage-2.2.x/run/tutorials/incompressible/icoFoam/cavity $ >

wyldckat September 10, 2013 17:13

Hi Mike,

This seems strange...
What happens if you run ParaView directly from the command line? Namely if you simply run:

Does it crash?

Best regards,

mpage September 10, 2013 17:16

Testing parax
Nope. The paraview window comes up as expected and stays until I dismiss it.

wyldckat September 10, 2013 17:42

OK, try replacing the 4 lines you have in ".alias" with this single one:

alias paraFoam="touch case.foam && /Applications/ --data=case.foam"
Then source the file:

source ~/.alias
Then go into a tutorial case where you have at least already generated the mesh and run:

If all goes well, it should work as intended.

mpage September 13, 2013 12:47

PV3Reader libraries missing
Still the same problem:


/Users/mpage/OpenFOAM/mpage-2.2.x/run/tutorials/incompressible/icoFoam/cavity $ > paraFOAM
+ unset FOAM_ABORT
+ unset regionName optTouch
+ export LC_ALL=C
+ extension=OpenFOAM
+ requirePV=1
+ '[' 0 -gt 0 ']'
+ '[' 1 -eq 1 -a '!' -f /Users/mpage/OpenFOAM/OpenFOAM-2.2.x/platforms/darwinIntel64GccDPOpt/lib/paraview-3.12/ ']'
+ cat

FATAL ERROR: ParaView reader module libraries do not exist

Please build the reader module before continuing:
cd $FOAM_UTILITIES/postProcessing/graphics/PV3Readers

+ exit 1
/Users/mpage/OpenFOAM/mpage-2.2.x/run/tutorials/incompressible/icoFoam/cavity $ > ls -l /Users/mpage/OpenFOAM/OpenFOAM-2.2.x/platforms/darwinIntel64GccDPOpt/lib/paraview-3.12/
ls: /Users/mpage/OpenFOAM/OpenFOAM-2.2.x/platforms/darwinIntel64GccDPOpt/lib/paraview-3.12/ No such file or directory
/Users/mpage/OpenFOAM/mpage-2.2.x/run/tutorials/incompressible/icoFoam/cavity $ >

wyldckat September 14, 2013 08:10

Hi Mike,

Mmmm... Perhaps you didn't notice this very important detail:

Originally Posted by
It is important to set as Format: Mac OS Extended (Case-sensitive,Journaled). The sparse image will grow with the place used inside the image. Create a sparse image with the following settings (examples, you could change the values):

The file system for installing OpenFOAM has to be case-sensitive because OpenFOAM relies very deeply in case-sensitivity. In your case, you should run:


One of the reasons for this is to instil in the user's mind that OpenFOAM and CFD is extremely sensitive to details! One dot in the wrong place and the simulation results you get are likely to be simply be garbage :( unless you're trying to create art ;)

Therefore, please try using the exact command:

Best regards,

infinitedreamer540 September 15, 2013 23:58

ParaView/paraFoam installation trouble
Hi guys,

I'm having the exact same problem; however, I'm much less familiar with open source software (and Terminal in general, I should clarify...) and have no idea what a .alias file is, or how to create/edit one. I've followed the instructions on the page and have all the OpenFOAM commands working properly up until the ParaView installation. Is anyone able to clarify those instructions, please? :)


ps. I should probably also add that I've searched all the corners of the internet that google will give me access to without any luck in finding a solution. >.<

wyldckat September 21, 2013 15:31

Greetings Rachel and welcome to the forum!

I've updated the instructions: - let me know if it's now easier to understand.

As for understanding how the terminal works:

Best regards,

infinitedreamer540 September 21, 2013 22:24

Thanks so much, Bruno! The clarifications were perfect, and I have paraFoam working seamlessly now. There was just one thing I had noticed: the wiki says to use the code


ls -s /Applications/ParaView\ $WM_PROJECT_DIR/bin/paraview
however, that one didn't work for me. Instead, I googled around a bit and tried ln -s instead of ls -s, for the following code:


ln -s /Applications/ParaView\ $WM_PROJECT_DIR/bin/paraview
and then everything else you had outlined, and it runs beautifully.

Thanks again for your help!


IdFx October 16, 2013 13:10

Installation problem
I m a french student in university of Rouen. I have to install paraFoam and can't make it!
I have this error message :

ew-host-4:OpenFOAM-2.2.0 IdFx$ ./Allwmake
./Allwmake: line 4: wmakeCheckPwd: command not found
Error: Current directory is not $WM_PROJECT_DIR
The environment variables are inconsistent with the installation.
Check the OpenFOAM entries in your dot-files and source them.

Do you have a solution to help me please?
Thank you

wyldckat October 16, 2013 15:05

Greetings IdFx and welcome to the forum!

There is absolutely no need to build ParaView/paraFoam on Mac OS X! Simply follow the instructions provided here: - namely in section "3 Installing and using ParaView".

Best regards,

IdFx October 16, 2013 15:09

Thank's fo your reply
It's not when I want to instal paraview this error appears when I try to install openFoam when the tutorial.
all seems to be good and when i try to install openFoam it doesn't work
i have to work on openfoam to study fluid modelisation for my 2nd master degree.

wyldckat October 16, 2013 15:13

If the problem is with building OpenFOAM 2.2, then please read this thread:

All times are GMT -4. The time now is 12:47.