CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   - missing (

anon_a April 24, 2012 09:38 missing
Hello everyone

While trying to fix something that was not even broken (:mad:) I managed to make my decomposePar stop working. Here is the message I get:


decomposePar: error while loading shared libraries: cannot open shared object file: No such file or directory
I searched a little bit around the forum and even though some posts helped me with other issues, I could not get pass this one. I am also confused because:
- even though "rpm -q scotch" reports that it is not installed, I could run decomposePar without problems yesterday
- I don't use scotch but a simple decomposition. But I did try to switch to scotch yesterday.

Some information that may help:
Linux version
gcc version 4.3.4, SUSE Linux
OF v2.1.0

wyldckat April 24, 2012 19:00

Greetings anon_a,

Mmm, by your description, it looks like you are using the RPM version of OpenFOAM for SuSE and openSUSE.
Depending on your system architecture, have you tried installing Scotch again as indicated here: - namely the point that starts with this text:

3. EITHER, download and install Scotch, Paraview and OpenFOAM for 32 bit
The other hypothesis is that you might have built OpenFOAM 2.1.0 from source, as explained here: - in this case, it would only be a matter of running "Allwmake" once again.

Best regards,

anon_a April 25, 2012 04:13

Thanks Bruno.
You were right, I had compiled from source (and thus the rpm command was totally stupid but I guess I was too tired and frustrated :-) )
./Allwmake solved my problem.

david112 April 6, 2017 05:12

5 years later it still solves the problem. Thanks for this thread! :cool:

All times are GMT -4. The time now is 17:20.