CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   CentFOAM Python Script Installation: Error (

socon009 May 24, 2012 10:16

CentFOAM Python Script Installation: Error
Hi all,

First things first - thanks to the contributors and developers out there who are helping to make this amazing software available to all.

Now, on to business.

I have been trying to install CentFOAM by using the python script supplied at the following website:

I continue by relocating the file to my preferred installation directory:


mv /home/username/centFOAM/
From that directory I begin to use the script:


python -h
sudo python --yum
python --nonOF

It is at this point that I encounter the following problem...


Traceback (most recent call last):
  File "", line 338, in <module>
  File "", line 297, in main
    installParaview(options.path, "3.10.0",rel)
  File "", line 167, in installParaview
    writeStartParaview(path, package, "paraview",version[:-2])
  File "", line 64, in writeStartParaview
    fileHandle = open ( fileName , 'w' )
IOError: [Errno 2] No such file or directory: '/home/shaun/centFOAM//paraview-3.10.0/bin/start_paraview'

This example is from the script's attempt to download, unpack, install ParaView. However, the problem was first encountered with NetGen. After consulting the script in gedit, I found that it seemed to get hung up on "unpacking" the .tar.gz compressed directory. So, as an experiment, I manually unpacked NetGen, which solved that error only to give the same error as before, except now with "ParaView" in the place of "NetGen" as you see in the code above.

My hunch is that the path is not being defined correctly. The reason I can be clearly viewed in the following code...


IOError: [Errno 2] No such file or directory: '/home/shaun/centFOAM//paraview-3.10.0/bin/start_paraview'
The path appears to include and extra forward slash between "centFOAM" and "paraview" in this example. Now, please pardon if this is acceptable file path syntax, as it is my first time encountering such an expression.

Continuing on this notion, I tried to find where in the script that the path was being defined. Unfortunately, I do not speak "python" very well and could only deduce that a variable referred to as "path" was being used in arguments, but I could not find the source of its definition.

Still, I noticed lines like this...


def writeTobashrc(path,version,name,extra):
    fileHandle = open ( os.environ['HOME']+"/.bashrc", 'a' )
    fileHandle.write ( 'alias '+name+'=\"'+path+'/'+name+'-'+version+'/'+extra+'\"\n' )

Notice the inclusions of a second forward slash directly following "path" in the third line. Assuming that the script takes its definition for path to be of the following format: /dir/dir/dir/ (ending with a "/"), then my guess is that this may be the source of my troubles.

As I type, I am flabbergasted. Since I hate to leave loose ends untied, I decided to post here in order to see if there is an easy solution while also providing documentation of this "bug" so others who encounter it in the future may rest easy knowing that they are not alone in their pain. :D

While I wait, hopefully, for a response to this thread, I will attempt to make small modifications in the python script to resolve the potentially problematic "//" phenomenon.

Thank you for reading!


socon009 May 24, 2012 11:14


Manually unpacking these files has worked. Each program is usable.

Still interested if anyone has any ideas about the python script though.


wyldckat May 26, 2012 09:36

Greetings Shaun,

Here's a recent thread about using CentFOAM: - I know, the title is misleading...

As for me, the day I tested using the script, was having existential problems, so I didn't trigger any of those bugs, since I ended up having to do more steps manually.

Best regards,

All times are GMT -4. The time now is 16:05.