MPI version issues with SUSE 12.1
I have a fresh install of OpenSUSE 12.1 and am trying to install a few pieces of software - particularly OpenFOAM ( The OpenFOAM® Foundation ).
I've tracked down the RPMs required (the link from their website was broken but I found a mirror) and successfully installed scotch and paraview (easily; clicked on the RPMs and apper installed them for me, no troubles).
However, when I try to install OpenFOAM with apper I get an error that a dependency on OpenMPI 1.5 (.x) is unresolvable. The SUSE repositories only contain up to 1.4.x. So, I download an RPM of OpenMPI 1.5 from pbone, and attempted to install at the same time. This time, the version of glibc (2.15) that OpenMPI 1.5 requires isn't available (only glibc 2.14 on the OpenSUSE repos).
You see where I'm heading (down a rabbit hole). I don't want to manually resolve dependencies for my entire system (figuring that by the time I'm messing with glibc, this could be a very deep hole).
I can't find the right repositories to add to allow apper to do it's job.
There's a potential solution using 'GeekoCFD' appliance from the SUSE Studio, which says they've used Third Party OpenMPI - but I have partitions I want to retain and therefore don't want to wipe the entire drive to install one of their images. I've googled for Third Party OpenMPI and can't find the packages they're mentioning.
Can anybody guide me in the best practice to use in this kind of situation please? (By 'best' I mean most user friendly to achieve a robust result...).
Thanks for any help, and best regards
By what I've tested now (following these instructions), it seems that you've made some very strange twists and turns on installing those packages. ;)
You didn't mention one particular detail: are you using openSUSE 32bit (i686) or 64bit (x86_64)?
The scotch package is indeed missing and I've reported this issue here: http://www.openfoam.org/mantisbt/view.php?id=592
Nonetheless, you can use this command (it will retrieve the library for openSUSE 11.4):
And what do you mean by a missing dependency on Open-MPI 1.5? :confused: I've tested installing this just now and only have Open-MPI 1.4.5 installed from openSUSE's normal repositories! And had no complains by rpm!?
I'm using openSUSE 12.1 x86_64 and fully up-to-date and rebooted machine.
As for Open-MPI, for it to work as intended, you'll need to run these commands:
After logging back in, simply run:
Hi wyldcat, thank you for your help; that has got me a little further.
The missing scotch link is what caused my problem with the OpenCFD site instructions; so I retrieved RPMs from elsewhere and tried to install them using the same procedure. The RPM I used must have been custom built by someone using OpenMPI 1.5 (it wasn't a typo), rather than a mirrored version of the OpenCFD one.
So, now I have OpenFOAM installed properly, although the latest OpenMPI version available on the repositories is 1.4.3 (see http://software.opensuse.org/package/openmpi which is consistent with the latest available version showing in my YAST) - so I don't know where you're getting 1.4.5 from!
The packages are missing a dependency on lam, which contains mpirun - so users may have to do:
sudo zypper install lam
which worked for me.
Then I got the issue described on this post:
Which is easily fixed following those instructions.
Thanks for your help, I think the problem is now solved!
Keep in mind that the updater needs to update in two stages:
Thanks for your clear explanations and patient help.
Despite several years and quite a lot of programming experience during my PhD, I still find linux administration extremely frustrating. Desperately keeping a huge rant on the SUSE forums inside me.
Thanks again, and best regards
|All times are GMT -4. The time now is 21:05.|