CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Compilation stuck on vorticity (

denismaloir August 4, 2012 03:17

Compilation stuck on vorticity

I've spent a few days now trying to compile OpenFOAM-1.6-ext with Ubuntu 12.04LTS and I haven't had any luck. I've tried many things: the instructions on openfoam wiki (cannot find ld things), instructions found on forums, the nucleation script, ... and everytime it failed to compile despite my starting from scratch (newly installed version of ubuntu on a VM).

I'm now following the instructions from sourceforge and everything seemes to go fine until it got stuck on


/home/nid/OpenFOAM-1.6-ext/lib/linux64Gcc46DPOpt/postCalc.o -lfiniteVolume -lOpenFOAM -liverty -ldl -lm -o /home/nid/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linux64Gcc46DPOpt/vorticity
And when I say stuck I mean that I started the compilation yesterday around 8AM, that I noticed its being stuck around 11pm and that it's now 9am...

So I don't know what I can do... can I just shut it down and launch the compilation again?

Thank you for your input!

denismaloir August 4, 2012 04:38

Well, I ended up stopping the compilation and ran it again.

A bunch of stuck is indicated as 'up to date', but it stays stuck just after


make[2]: '/home/nid/OpenFOAM/OpenFOAM-1.6-ext/applications/bin/linux64Gcc46DPOpt/SurfaceTransformPoints' is up to date.
And it's been right there for over 1hr now.

How long does it normaly take to compile OpenFOAM?

wyldckat August 4, 2012 06:05

Greetings Denis,

It depends on the CPU power of the machine, amount of RAM and how many cores are available. Here are some timing examples: Build times for OpenFOAM 2.0.x code with Ubuntu 10.10 with its gcc 4.4.5

From my experience, it can take 8h on very slow machines, using single core; down to 30 minutes, using multi-core.

So, a few questions:
  1. How much RAM did you allocate to your virtual machine?
  2. How many virtual cores did you assign to it?
  3. What virtualization software and version are you using?
It could be in fact a problem with the virtualization software and/or version, because Ubuntu 12.04 is still relatively recent and there are some issues with older virtualization tools.

Best regards,

denismaloir August 4, 2012 07:29


Thank you for your answer!

Up to now, I allocated a single core (i5 2500K) and 4GB of RAM (out of 16). I'm running Virtual Box 4.1.18.

As of this moment, it's still stuck with no error message, it just looks like it's running but nothing happens. The VM is functional (that is, I can launch other softwares) so it's not like the whole VM froze suddenly. If it stays like this, I might end up killing the process again and restarting the VM with 2 or 3 cores, just to check if it changes anything.

In that case, I guess I should hit 'export WM_NCOMPPROCS=2' (or 3) in the terminal prior to compiling?

wyldckat August 4, 2012 07:46

From my experience, using multi-core was more prone to these kinds of lockups; on other situations, it was due to virtualization issues, specially with Ubuntu 12.04. You would probably have lesser problems with Ubuntu 11.10 or even 10.04. I haven't tried Mint either, so that's another possibly healthy possibility.

You might already know this from the nucleation project and all other attempts you've made, but try running Allwmake like this:

./Allwmake > make.log 2>&1
On another terminal, to see how it's going, run:

tail -F make.log
When it seems to lock up, Ctrl+C on the terminal where you're doing the tail and check if there are any errors by running:

grep "Error " make.log
As for using multi-core, you're basically correct:

./Allwmake > make.log 2>&1

denismaloir August 4, 2012 08:00

I thought so too with the number of cores, I remember reading something somewhere that compiling on 1 core was a conservative choice.

As for tailing the log, I indeed did that and couldn't find any error. I ran it again and it quickly came to be stuck again at the same point.

Anyway, I think I will follow your advice and install ubuntu 10.xx and run it again.

(I'll be back! :p)

denismaloir August 5, 2012 03:49

everything was fine!

Well, it took me the entire setup of Ubuntu 10.04 along with the compilation of the ThirdParties to understant that ... there was no problem at all.

I was tailing the log in the same terminal as I was compiling OpenFOAM, hence I didn't notice that it, in fact, finished compiling. The terminal was doing what it was supposed to do, echoing the last line of the log.

If I had just run foamInstallationTest (and Googled the 'tail' command...), I would have spared a few hours of my life ...

Anyway, than you for your help, and sorry for the stupid questions! I'll try and use my brain next time.

All times are GMT -4. The time now is 12:04.