CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   how to use paraview-3.14 on OpenSUSE 12.2 with OpenFOAM-2.1.x? (

phsieh2005 September 26, 2012 08:12

how to use paraview-3.14 on OpenSUSE 12.2 with OpenFOAM-2.1.x?
Dear OpenFOAMers,

Is there a way to use Paraview-3.14 with OpenFOAM-2.1.x on OpenSUSE 12.2? I downloaded the binary version, but, whenever I tried to run the binary version on OpenSUSE 12.2 (64 bit), I got "segmentation fault".

Any suggestion?


wyldckat October 2, 2012 16:59

Hi Pei-Ying,

I didn't see this thread of yours where you had placed it, namely at the sub-forum for post-processing. I've moved the thread to here to the installation sub-forum.

As for using the pre-built ParaView 3.14.1 in openSUSE 12.2:
  • I've finished testing just now in a virtual machine with openSUSE 12.2 64bit installed in it and followed the instructions I've written here:
  • I adjusted the versions accordingly where necessary, so it would use the tarballs for 3.14.1, instead of 3.10.1.
  • As for OpenFOAM itself, the instructions for 2.0 are identical for 2.1 as well.
Since I tested this in a virtual machine, I might not be triggering the segmentation fault you're getting, because in the virtual machine I don't need to use NVidia nor ATI graphics card drivers.

Best regards,

PS: I think I've seen a thread of yours on the ParaView mailing list (this one) and I noticed that you haven't specifically mentioned that you were using Qt 4.8.1, which would be the reason why you're getting the errors mentioned on that thread at the mailing list.

phsieh2005 October 2, 2012 18:39

Hi, Bruno,


I ended up compiling the paraview.3.14.1 from source and used the patch posted by Pablo. OpenSUSE came with QT 4.8.1. I do not know how to downgrade to QT 4.6. But, compiling from source with the patch worked on opensuse 12.2, though.

Apparently the paraview team is aware of the stl ASCII issue. A fix is under review.

But, I still have no clue why I cannot run the paraview development version compiled on opensuse 12.2.


All times are GMT -4. The time now is 18:01.