CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Installing OpenFOAM 2.1.1 and ParaView 3.12.0 on Ubuntu 12.10 (

wyldckat October 5, 2012 07:46

Installing OpenFOAM 2.1.1 and ParaView 3.12.0 on Ubuntu 12.10
Greetings to all!

Since today is a holiday here in Portugal, I took the liberty to do some preemptive testing of installing OpenFOAM 2.1.1 on Ubuntu 12.10 aka Quantal, which has recently reached beta stage.

Problems installing on this new release was expected, so I've added instructions for it here:

I did the tests only on a virtual machine with Ubuntu 12.10 x86_64 and everything built without any problems, as long as those instructions are properly followed ;)
Nonetheless, I'm expecting problems with real machines, because graphics card drivers can be a serious pain sometimes...

Anyway, if anyone has problems installing and using OpenFOAM 2.1 and ParaView 3.12.0 on Ubuntu 12.10, feel free to use this thread!

Best regards,

tarigarma November 6, 2012 07:04

I have tried this with a real machine and it works perfectly also.

thanks for your post

khashi November 7, 2012 17:42

Thank you
I followed your instructions and it works. Thank you so much.

wyldckat November 22, 2012 04:55

How to get started?!

For people having trouble getting started, go to this thread:


Armandul December 2, 2012 06:12

Hey there,
i have a big problem with this installation.
it seems like everything went well and when i try to do the first tutorial showing the mesh with paraFoam it generates an error telling me about segmentation violation.
opening paraview is possible, but not paraFoam.

i have an laptop with the NVIDIA GeForce 9300M G.
it does not work either with proper driver installed or with default one.

some ideas or same problems?

thanks a lot!

wyldckat December 2, 2012 07:40

Greetings Michael,

I was expecting that sooner or later someone would report problems with an NVidia or ATI card ;)

So, let's try and isolate the problem:
  1. Try using the internal reader:

    paraFoam -builtin
  2. Do you have another installation of ParaView in your Ubuntu installation? Or in other words, have you installed Ubuntu's default ParaView?
  3. With either ParaView, try creating a new object. In the menu "Source", choose "Sphere" and hit the "Apply" button. Does it also give a segmentation fault?
  4. If you haven't tried Ubuntu's own ParaView, then install it. You can install it by running:

    sudo apt-get install paraview
    Then go into the case folder you were testing before and run:

    paraFoam -builtin -touch
    Then open ParaView via the global Ubuntu menu (or whatever they call it now :( "dashboard" maybe?). And open the created file, possibly named "cavity.foam" in the case folder you were testing in.
Depending on the outcome of these tests, we should be able to figure out a solution!

Best regards,

Armandul December 2, 2012 08:32

Hello Bruno,

first of all, i want to thank you for your amazing fast reply!
actually i have no idea what happend there, but now it works without doing anything.
i mean i did the same things as before. maybe some new driver is implementet since yesterday in the automatic update package?

but anyway, thanks a lot!

protussa January 29, 2013 12:45

Thanks. worked for me.
changed the VERS to precise and followed the Ubuntu Deb Pack Installation instructions.

Muhammad_Omer February 8, 2013 03:38

problem loading paraview on ubuntu 12.10
Dear All

I have installed open foam 2.1.1 on unbuntu12.10 with the help of hack that bruno provided i.e change precise to quantal but the problem is when I try to post process my results in paraview it gets crashed.If some one has done the cavity tutorial so for them when I reach the step where I try to got to the filters the moment I click it it crashed.Can any one help me on this

wyldckat February 8, 2013 04:29

Greetings Muhammad and welcome to the forum!

Try these steps:
  1. Switch to "root" mode:

    sudo -s

    su -
  2. Uninstall OpenFOAM's ParaView and install Ubuntu's version:

    apt-get remove paraviewopenfoam3120
    apt-get install paraview

  3. Go into the folder where OpenFOAM is installed, more specifically to the "bin" folder it has got. If I'm not mistaken, it should be in your case:

    cd /opt/openfoam211/bin
  4. Now run these two commands:

    sed -i -e 's/requirePV=1/requirePV=0/' paraFoam
    sed -i -e 's=\.OpenFOAM=\.foam=' paraFoam

    The first command is just a precaution.
  5. Exit "root" mode:

  6. Go to one of the folders where you have an OpenFOAM case and try running paraFoam in it. It should now work as intended!
Best regards,

Muhammad_Omer February 10, 2013 03:19

problem persists
Dear Brono

Thanks for your quick reply but the problem is still there.I tried reinstalling openfoam following the steps on

and after that used the commands that you had provided but it still crashes on going to the filter options and the screen goes blank with the following messages:
starting system V run level compatibility [ok]
starting [ok]

starting [ok]
stopping [ok]

starting CUPS printing spooler/server [ok]

starting cold plug devices [ok]

Please help me as soon as possible coz I am loosing valuable research time

Muhammad Omer Mughal

wyldckat February 10, 2013 06:46

Hi Muhammad,

Looks like you need to install the correct drivers for your machine's graphics card!
Search online through Google or some other search engine, for the following keywords:

install graphics card drivers in Ubuntu
Good luck!

Muhammad_Omer February 11, 2013 03:42

Dear Brono

Thanks for your help and time.The problem is fixed and I can now work at ease on OpenFOAM in ubuntu 12.10. Ru doing research on OpenFOAM or r u dong a job.


Muhammad Omer Mughal

peteryuan February 12, 2013 04:01

Thanks Bruno
I changed the VERS to precise and everything worked fine for me last night.
As a beginer for Ubuntu and OpenFOAM, I have tried such a long time to install OpenFOAM. Finally it worked. So, thanks for your help, Bruno!

I did paraFoam in cavity case and everything went well.

then I suppose that you can do paraFoam in every tutorial case, right? I tried to do paraFoam in some other case directories, it did not work.
the error of paraview said that there are some error in line so and so, or invalid mesh or something like that.
I just want to know it that normal for some cases in tutorial?
Or do I have problems with my installation if that happened?
Thanks for your help!

wyldckat February 12, 2013 05:43

Greetings Peter and welcome to the forum!

First, read the user guide and follow the detailed tutorials there: ;)

Then, depending on the tutorial:
  1. Look for a file named Allrun in the case's folder or parent folder. If there is one, you can run it with:

    Feel free to edit the file, to learn which commands are used.
  2. If there is none, simply run:

Only then can you use paraFoam.

Best regards,

All times are GMT -4. The time now is 22:11.