CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   fireFoam.1.7.x_0.4 compilation error (

!link October 8, 2012 19:41

fireFoam.1.7.x_0.4 compilation error
I'm sorry, I didn't realize the text of this message had for some reason not copied off my computer!
In any event, my question regarding the compilation of fireFoam is as follows:

Hi All!

I used makaveli_lcf's method for installing OpenFOAM 1.7.1 on 12.04 (found here) without any problems, but then when I tried to install the "newest" fireFoam from here I am receiving a strange compilation error when calling ./Allwmake in my downloads folder.

My understanding was that if I got OpenFoam 1.7.1 installed correctly, I should be able to install fireFoam from anywhere and then just drop it into /opt/openfoam171/.. once it had compiled.

Thanks for your help!

~/Downloads/fireFoam.1.7.x_0.4$ sudo ./Allwmake
+ ./libs/Allwmake
+ ./thermophysicalModels/Allwmake
+ wmake libso additionalReactionsNew
./thermophysicalModels/Allwmake: 5: ./thermophysicalModels/Allwmake: wmake: not found
+ wmake libso reactionThermoNew
./thermophysicalModels/Allwmake: 6: ./thermophysicalModels/Allwmake: wmake: not found
+ wmake libso SLGThermo
./thermophysicalModels/Allwmake: 7: ./thermophysicalModels/Allwmake: wmake: not found
+ wmake libso combustionModelsSpecies
./thermophysicalModels/Allwmake: 8: ./thermophysicalModels/Allwmake: wmake: not found
+ wmake libso chemistryModelNew
./thermophysicalModels/Allwmake: 9: ./thermophysicalModels/Allwmake: wmake: not found
+ wmake libso radiationModelNew
./thermophysicalModels/Allwmake: 10: ./thermophysicalModels/Allwmake: wmake: not found
+ ./basicSolidThermo/Allwmake
+ wmake libso solid
./basicSolidThermo/Allwmake: 5: ./basicSolidThermo/Allwmake: wmake: not found
+ wmake libso basicSolid
./basicSolidThermo/Allwmake: 6: ./basicSolidThermo/Allwmake: wmake: not found
+ wmake libso chemistryModel
./basicSolidThermo/Allwmake: 7: ./basicSolidThermo/Allwmake: wmake: not found
+ ./regionModels/Allwmake
+ wmake libso regionModel
./regionModels/Allwmake: 5: ./regionModels/Allwmake: wmake: not found
+ wmake libso pyrolysisModels
./regionModels/Allwmake: 6: ./regionModels/Allwmake: wmake: not found
+ wmake libso surfaceFilmModels
./regionModels/Allwmake: 7: ./regionModels/Allwmake: wmake: not found
+ wmake libso regionCoupling
./regionModels/Allwmake: 8: ./regionModels/Allwmake: wmake: not found
+ wmake libso lagrangian/basicNew
./libs/Allwmake: 7: ./libs/Allwmake: wmake: not found
+ wmake libso lagrangian/intermediateNew
./libs/Allwmake: 8: ./libs/Allwmake: wmake: not found
+ ./solvers/Allwmake
+ ./fireFoam/Allwmake
+ wmake libso thermophysicalModels/combustionModels
./fireFoam/Allwmake: 5: ./fireFoam/Allwmake: wmake: not found
+ wmake libso thermophysicalModels/radiation/submodels/absorptionEmissionModel/greyMeanAbsorptionEmissionSoot
./fireFoam/Allwmake: 6: ./fireFoam/Allwmake: wmake: not found
+ wmake libso thermophysicalModels/radiation/derivedFvPatchFields/greyDiffusiveRadiation
./fireFoam/Allwmake: 7: ./fireFoam/Allwmake: wmake: not found
+ wmake libso fvPatchFields
./fireFoam/Allwmake: 8: ./fireFoam/Allwmake: wmake: not found
+ wmake libso fvPatchFieldsPyrolysis
./fireFoam/Allwmake: 9: ./fireFoam/Allwmake: wmake: not found
+ wmake libso functionObjects
./fireFoam/Allwmake: 10: ./fireFoam/Allwmake: wmake: not found
+ wmake
./fireFoam/Allwmake: 11: ./fireFoam/Allwmake: wmake: not found
+ ./utilities/Allwmake
+ ./extrudeToRegionMesh/Allwmake
+ wmake libso extrudeModel17x
./extrudeToRegionMesh/Allwmake: 5: ./extrudeToRegionMesh/Allwmake: wmake: not found
+ wmake
./extrudeToRegionMesh/Allwmake: 6: ./extrudeToRegionMesh/Allwmake: wmake: not found
+ ./mapFields/Allwmake
+ wmake
./mapFields/Allwmake: 5: ./mapFields/Allwmake: wmake: not found
+ ./decomposeParPyr/Allwmake
+ wmake libso decompositionMethodsPyr
./decomposeParPyr/Allwmake: 5: ./decomposeParPyr/Allwmake: wmake: not found
+ wmake
./decomposeParPyr/Allwmake: 6: ./decomposeParPyr/Allwmake: wmake: not found

!link October 9, 2012 18:00

Note that I have already ensured that my bashrc file is correct


$ tail -1 ~/.bashrc
. /opt/openfoam171/etc/bashrc

and that from the command prompt I can run OpenFoam commands


$ icoFoam -help

Usage: icoFoam [-parallel] [-case dir]  [-help] [-doc] [-srcDoc]

So I am not really sure what the problem is. Any and all suggestions would be appreciated. Thank you!

kev4573 October 9, 2012 23:25

You are running Allwmake with sudo, which changes your environment to that of root. Run 'sudo env' so you see what I mean; none of your openfoam variables will be defined in the sudo environment. Try sudo -E env PATH=$PATH ./Allwmake if you must build as root. If you can, just build as a regular user.

!link October 10, 2012 12:39

Thanks for your reply kev4573!

I guess I misunderstood what I needed to do. I was able to compile fireFoam by calling calling ./Allwmake and it seemed to run just fine.

Now though, when I try to run test cases from the testBatteryFireFOAM sub directory, I am receiving fatal errors when I attempt to run the test cases.

Any thoughts on the matter? Thanks again for your help!


~/fireFoam/testBatteryFireFOAM/wallSuppression$ cat log.fireFoam
| =========                |                                                |
| \\      /  F ield        | OpenFOAM: The Open Source CFD Toolbox          |
|  \\    /  O peration    | Version:  1.7.x                                |
|  \\  /    A nd          | Web:                      |
|    \\/    M anipulation  |                                                |
Build  : 1.7.x-131caa989cd3
Exec  : fireFoam
Date  : Oct 10 2012
Time  : 09:32:28
Host  : ratatoskr
PID    : 12616
Case  : /home/angel/fireFoam/testBatteryFireFOAM/wallSuppression
nProcs : 1
SigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0

Reading g
Reading thermophysical properties

Selecting thermodynamics package hsPsiMixtureThermoNew<singleStepReactingMixture<gasThermoPhysics>>

Unknown hsCombustionThermo type hsPsiMixtureThermoNew<singleStepReactingMixture<gasThermoPhysics>>

wyldckat October 10, 2012 15:33

Greetings to all!

This has already been addressed on another thread. Please start reading here: post #7
It doesn't hurt if you read the posts before that as well ;)

Best regards,

!link October 11, 2012 11:34

Thanks for the clarification Bruno!

I appreciate the help! I will definitely read that thread and install 1.7.x instead of 1.7.1.

Update: So I attempted to install 1.7.x based on the link here as recommended by Bruno. I ran ./Allwmake in the subfolder of of my home folder where OpenFOAM resides.

About an hour in, the compilation seems to end, but the last result is troublesome:

make[2]: Entering directory `/home/angel/OpenFOAM/OpenFOAM-1.7.x/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
SOURCE=mixtureAdiabaticFlameT.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/home/angel/OpenFOAM/OpenFOAM-1.7.x/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/home/angel/OpenFOAM/OpenFOAM-1.7.x/src/OpenFOAM/lnInclude -I/home/angel/OpenFOAM/OpenFOAM-1.7.x/src/OSspecific/POSIX/lnInclude  -fPIC -c $SOURCE -o Make/linux64GccDPOpt/mixtureAdiabaticFlameT.o
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3  -DNoRepository -ftemplate-depth-40 -I/home/angel/OpenFOAM/OpenFOAM-1.7.x/src/thermophysicalModels/specie/lnInclude -IlnInclude -I. -I/home/angel/OpenFOAM/OpenFOAM-1.7.x/src/OpenFOAM/lnInclude -I/home/angel/OpenFOAM/OpenFOAM-1.7.x/src/OSspecific/POSIX/lnInclude  -fPIC -Xlinker --add-needed Make/linux64GccDPOpt/mixtureAdiabaticFlameT.o -L/home/angel/OpenFOAM/OpenFOAM-1.7.x/lib/linux64GccDPOpt \
        -lspecie -lOpenFOAM -ldl  -lm -o /home/angel/OpenFOAM/OpenFOAM-1.7.x/applications/bin/linux64GccDPOpt/mixtureAdiabaticFlameT
make[2]: Leaving directory `/home/angel/OpenFOAM/OpenFOAM-1.7.x/applications/utilities/thermophysical/mixtureAdiabaticFlameT'
make[1]: Leaving directory `/home/angel/OpenFOAM/OpenFOAM-1.7.x/applications/utilities/thermophysical'
make: Target `application' not remade because of errors.

I have made sure that I have the most recent version of the git repository:

$ git log -1
commit d08d3c27ccda228b4d41cf13212e6efc4f419b0e
Author: mattijs <mattijs>
Date:  Thu Jul 14 22:08:27 2011 +0100

And that I am using a version of gcc-4.4 as I have read that using a newer version of gcc can cause issues:

$ gcc --version
gcc (Ubuntu/Linaro 4.4.7-1ubuntu2) 4.4.7

Any thoughts or suggestions would be greatly appreciated as I try to solve this problem!

wyldckat October 13, 2012 06:24

OK, took me a while to test this. Follow these instructions: - but adapt where necessary for 1.7.x.

babakflame December 2, 2012 12:57

Dear buddies
I want to know what is the combustion models available in firefoam. would somebody plz hint me?:):):)

trinath2rao December 17, 2012 05:41

firefoam : compilation problem

I have compiled firefoam succesfully but while running the case from tutorials.I am facing problem with fatal eror.

can anyone suggest me where am i going wrong

below is the error :

Unknown hsCombustionThermo type hsPsiMixtureThermoNew<singleStepReactingMixture<ga sThermoPhysics>>

Valid hsCombustionThermo types are:

hsPsiMixtureThermo<dieselMixture<sutherlandTranspo rt<specieThermo<janafThermo<perfectGas>>>>>
hsPsiMixtureThermo<homogeneousMixture<constTranspo rt<specieThermo<hConstThermo<perfectGas>>>>>
hsPsiMixtureThermo<homogeneousMixture<sutherlandTr ansport<specieThermo<janafThermo<perfectGas>>>>>
hsPsiMixtureThermo<inhomogeneousMixture<constTrans port<specieThermo<hConstThermo<perfectGas>>>>>
hsPsiMixtureThermo<inhomogeneousMixture<sutherland Transport<specieThermo<janafThermo<perfectGas>>>>>
hsPsiMixtureThermo<multiComponentMixture<gasThermo Physics>>
hsPsiMixtureThermo<reactingMixture<gasThermoPhysic s>>
hsPsiMixtureThermo<veryInhomogeneousMixture<constT ransport<specieThermo<hConstThermo<perfectGas>>>>>
hsPsiMixtureThermo<veryInhomogeneousMixture<suther landTransport<specieThermo<janafThermo<perfectGas> >>>>

From function hsCombustionThermo::New(const fvMesh&)
in file combustionThermo/hsCombustionThermo/newhsCombustionThermo.C at line 65.

FOAM exiting

Thank You :)


trinath2rao December 24, 2012 05:15


I got it working and compiled succesfully.

Thank You

Trinath Rao

All times are GMT -4. The time now is 05:53.