CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   problem with parmetis-3.1.1 installation for openfoam 1.6-ext (

achyutan October 15, 2012 08:24

problem with parmetis-3.1.1 installation for openfoam 1.6-ext
1 Attachment(s)

I am currently using OF 2.0.1. I have been unsuccessfully trying to install 1.6-ext (in addition to 2.0.1) for few days now. I am using ubuntu natty.
In Thirdparty stage3 compilation, parmetis-3.1.1 is not getting installed for unknown reasons. As suggested in previous threads, I downloaded separately parMetis-3.1.1.tar.gz into ThirdPatry/rpmBuild/SOURCES. Stil, getting the same errors with parmetis installation.
I have attached the log file of stage 3 compilation for reference.
I kindly request help in this regard.


achyutan October 17, 2012 07:43

I am still waiting for some help so that I can install OF1.6-ext as soon as possible.

I kindly seek a quick help.

any further detail needed ?

wyldckat October 18, 2012 03:54

Greetings achyutan and welcome to the forum!

I moved this thread to the installation sub-forum. If questions aren't asked in the right sub-forums, the chances of getting a timely answer can drop considerably :(

How are you keeping OpenFOAM installations separated? Are you using aliases for handling each separate OpenFOAM environment?
If you don't understand what I mean, check this blog post: Advanced tips for working with the OpenFOAM shell environment

As for the building log, it looks like you're using the system's MPI library, which seems to somehow be incompatible with ParMetis. Try switching to the MPI library that 1.6-ext uses by default.

By the way, which installation instructions are you following?

Best regards,

achyutan October 18, 2012 06:32

1 Attachment(s)
Yes, I am using aliases separately for 2.0.1 and 1.6-ext. I have been using 2.0.1 for sometime now ; so I have a decent experience in this.
I thought system's MPI is being used by default as I had not made any changes in mpi specification in inside OpenFOAM-1.6-ext/etc. I have attached the file here.

Could you tell me how to switch to the mpi meant for 1.6-ext ?

I am following the instructions given in :http://openfoam-extend.git.sourcefor...4.3_32-bit.txt
and the one found in OpenFoam website under installation using git repository.

@Bruno : thanks for that kind help. I would have it mind from next time to post under appropriate sub-forums.


wyldckat October 18, 2012 16:07

Hi achyutan,

Try running this command:

ls -l $WM_THIRD_PARTY_DIR/packages/openmpi-1.4.3/platforms/$WM_OPTIONS
If it shows a detailed list about these folders:

bin  etc  include  lib  share
then there shouldn't be any problems... unless something strange is going on :(
If it doesn't show anything, then check the log for "stage2".

Beyond this, I'll have to test this on a virtual machine... which I might be able to do this weekend...

Best regards,

wyldckat October 20, 2012 14:35

Hi achyutan,

I've tested in a virtual machine with Ubuntu 11.04 (Natty) i686 installed in it and I have not been able to reproduce the error you got :(

Additionally, I found out it's best to follow more closely the instructions for 12.04 than the ones for 10.04. I've compiled the steps I've taken here:

Best regards,

achyutan October 22, 2012 06:52

1 Attachment(s)
Sorry for the late response. I was away during the weekend.

thanks for that info.
yes, i can find the folders - bin share lib etc include.
later, I tried out the instructions given in that link and I got the same errors regarding parmetis installation.
This time, paraview-3.12 also did not get installed during stage4. But, I already have 3.8.0 installed in my system. so that should not be a problem.

thanks for spending time in my problem. I don't know how i am facing those errors given the fact you have shown it is possible to install it in ubuntu natty.
btw, i am using ubuntu natty x86_64.
I have attached the log file for thirdpart AllMake.
could you hint at any other possible mistake i could have made?


wyldckat October 22, 2012 08:56


which mpicc
If it is not picking the one from that other folder for openmpi-1.4.3, then that's why you're having problems. To fix this, try:

export PATH=$WM_THIRD_PARTY_DIR/packages/openmpi-1.4.3/platforms/$WM_OPTIONS:$PATH

achyutan October 23, 2012 08:46

Hi Brunos,

yeah, it gives the proper location of mpicc : ThirdParty/packages/openmpi-1.4.3/platforms/linux64GccDPOpt/bin/mpicc
I did not understand what you meant by 'the other folder for openmpi-1.4.3'. I also tried exporting the path as per your instruction, sourced the bashrc file and then ran AllMake only to get the same errors.

Did you mean : which parmetis
i thought there was no problem with installation of mpi.


wyldckat October 23, 2012 15:17

Hi achyutan,

I meant to say "from that other folder on post #5", namely the one for openmpi-1.4.3.

OK, I've compared the two logs, the one you've got and the one I got and the error occurs when building the test applications. These do not refer directly to "" (i.e. don't have "-lmpi"), which leads me to believe that you're using another version of the ld utility. If you run the following command:

ld --version
does it show this output :confused::

GNU ld (GNU Binutils for Ubuntu)
Copyright 2011 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or (at your option) a later version.
This program has absolutely no warranty.

The first line is the most relevant one. You can also check by running this command:

ls -l $(which ld)
It should show you something like this:

lrwxrwxrwx 1 root root 6 2012-10-20 14:56 /usr/bin/ld -> ld.bfd
If it does not, then it's because you're using a non-standard ld utility, which would explain the problems you're having!

Best regards,

achyutan October 25, 2012 05:39

Hi Bruno,

I tried those commands. It gave proper output as expected ; ld utility seems to be standard one.

I removed 1.6-ext completely from the system and tried to begin all over again. I got stuck with the same errors at stage 3 of thirdParty compilation.


wyldckat October 26, 2012 18:18

Hi achyutan,

I suggest that you try continuing with the instructions and build OpenFOAM itself as well. Some of OpenFOAM's decomposition related libraries won't build, but most of it should build.

But I suspect that there will be more problems than the ones related to those decomposition libraries, because the error given for ParMetis seems to be related to the aforementioned ld issue.

Without being able to test this myself, the fix shown here should help: - in other words, the following options should be added to the mpicc building command:

-Xlinker --add-needed -Xlinker --no-as-needed
Said command seems to be in "ThirdParty/rpmBuild/BUILD/ParMetis-3.1.1/".

Best regards,

All times are GMT -4. The time now is 16:02.