CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Installation OpenFOAM2.1.1 on Suse12.2 (

JJS October 22, 2012 06:21

Installation OpenFOAM2.1.1 on Suse12.2
3 Attachment(s)
Dear all,

I am trying to compile the OpenFOAM 2.1.1 source on my OpenSuse 12.2 (x86_64) installed system. After I tried compiling OF with the standard settings (failed), I changed the following:
__________________________________________________ _______________________
1) in /opt/OpenFOAM/ThirdParty-2.1.1/etc/wmakeFiles/scotch/ the following libraries are added: LDFLAGS += -L/usr/lib64/mpi/gcc/openmpi/lib64/ -L/usr/lib64 -lz -ldl -lrt -lglib-2.0 -L/usr/lib64 -lQtCore -lpthread

2) In /opt/OpenFOAM/OpenFOAM-2.1.1/etc/bashrc: WM_COMPILER=Gcc47, WM_MPLIB=SYSTEMOPENMPI.

3) In /opt/OpenFOAM/OpenFOAM-2.1.1/etc/config/ the versions are set according to the system installed version numbers: gcc_version=gcc-4.7.2, gmp_version=gmp-5.0.5, mpfr_version=mpfr-3.1.0, mpc_version=mpc-0.8.2, gmpPACKAGE=gmp-5.0.5

4) In /opt/OpenFOAM/OpenFOAM-2.1.1/wmake/rules/General/general I added library paths for libptscotch and libPstream, without success I think because gcc isn't able to find the libraries.

GINC = -I/opt/OpenFOAM/ThirdParty-2.1.1/platforms/linux64Gcc47DPOpt/lib/openmpi-system
GINC += -I/opt/OpenFOAM/OpenFOAM-2.1.1/platforms/linux64Gcc47DPOpt/lib/dummy
__________________________________________________ _______________________

I have no clue anymore what to do? Can somebody give me suggestions about what to do next? I added the output of the compilation process in a separate file (3 parts).

Thanks for your help

wyldckat October 22, 2012 09:01

Greetings Jos and welcome to the forum!

That's a lot of modifications... not sure why you needed so many.
You can try these instructions instead:

Additionally, I suggest that you try doing these in your home folder first, to avoid accidentally erasing/modifying your system.

Good luck!

JJS October 22, 2012 09:46

Thanks Bruno for your quick reply and for welcoming me at the forum!

Before doing any of the modifications, I already followed the instructions you mentioned without any success. So all necessary packages are installed and the environmental variables (via bashrc) are loaded.

The first error I ran into I solved by making the first adjustment in the scotch settings file. Because there were more errors popping up (actually the ones that are still in the current make.log files) I made the other changes. So, those changes are maybe not necessary!

I also tried to compile a version in the home directory, but since I got the same problems as in /opt/.... I decided to continue in the latter one that has my preference.

Apparently on my system for one reason a standard compilation doesn't work. Also the various posts I found on the internet didn't help me out!

Can you please have a look at the output and see if you have any guess about what can be wrong?

Thanks, Jos

wyldckat October 22, 2012 10:03

From what I can see, "" is missing. It should have been installed with the "devel_C_C++" pattern...

wyldckat October 22, 2012 15:50

Hi Jos,

I took a look at this just now and found out what the names for the zlib packages are. So could you try the following commands:

su -
zypper install zlib zlib-devel

This way it should at least clear up the first problem of "" not being found.

If after this it still has problems, then it might be due to at least either one of the following:
  • If you installed some other compiler tools, those might be affecting the compilation of OpenFOAM. Such tools would be to install another ld version/variant which has been advised for CUDA, at least in Ubuntu.
  • If you installed another version of OpenFOAM, its environment could be affecting the one on this version.
And I can't remember anymore possibilities... too tired.

Good luck! Best regards,

JJS October 23, 2012 05:46

Dear Bruno,

I appreciate your help, even in the evening hours :)

Zlib an Zlid-devel are installed so that can't be the problem. Also the system is just reinstalled and no other OpenFOAM versions are installed.

Your other remarks "forced" me to try a fresh installation because:
1) the home drive is now also being formatted as well. This was not done the previous time and you never know what traces (initially somebody else used this system) are left that might mess up the compilation.
2) last time I installed the complete development RPM group. This led to some problems and in the end it might indeed pose a problem. This time I will only install the missing and required packages and not all.

I am now busy with reinstalling the system. I will let you know whether it helped or not!


JJS October 24, 2012 03:44

Dear Bruno,

The problem is solved! As mentioned in the previous post, I started with a clean installation of Suse12.2. Only things I changed since the previous installation is: 1) formatting /home (ext4 instead of ext3) 2) installation of only the necessary packages/libraries and not the complete development group.

So I guess, like you mentioned, some packages conflicted each other in some way or the other.

The reason for me to download the whole development group was that at first I wanted to install the suse RMP pack installation of OpenFOAM. And for this, on the openfoam website it is mentioned that the development pack must be installed.

Although I don't really understand what the exact cause was, I am glad it is working now! Thanks for your support.


All times are GMT -4. The time now is 11:10.