CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Problem running tutorial (

vrolin November 27, 2012 07:23

Problem running tutorial
I've seen this posted elsewhere, but the solutions don't seem to apply to my case.

I'm running OpenFOAM on Ubuntu in VirtualBox. I followed the instructions to install the Ubuntu Deb pack from the OpenFOAM website:

When I run icoFoam -help, I get the usage message as expected.

However I run the tutorial using the sequence

blockMesh and icoFoam run without error,
but paraFoam generates the error message:
OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU
OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU

paraview opens and displays a grey 3D block.

Thanks so much for your help

treima November 27, 2012 07:42


have you changed the settings in Paraview, that it displays the solution? From SolidColor to one of your variables?



vrolin November 27, 2012 07:49

Hi Treima
I haven't changed any of the settings in Paraview,
I'm new to all of the software I'm using here and wouldn't have the first clue how.

treima November 27, 2012 08:36

Play a little bit around with the parameters in Paraview or do some online research, I think that will help you a lot.

For your special case, have a look at the description of the tutorial:



vrolin November 27, 2012 11:21

Thanks again,
This helped me understand how to view results in Paraview, but when I try to look at a variable like pressure, I still only see a blank surface.
I noticed while looking at the output of icoFoam, I see a time step continuity error at several iterations.

wyldckat November 27, 2012 18:19

Greetings to all!

I'm too tired right now to go through my blog post Related issues to ParaView with OpenFOAM - Fixes and solutions
Check the links provided there and do let us know if one of them is of any help!

Good luck!

Jaggy_Snake November 30, 2012 09:12

Is 3D acceleration turned on in your VB? I think I was getting a similar error until I disabled it... Could be wrong though

All times are GMT -4. The time now is 21:48.