CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Problem running tutorial

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 27, 2012, 07:23
Default Problem running tutorial
  #1
New Member
 
Vincent Rolin
Join Date: Nov 2012
Posts: 3
Rep Power: 6
vrolin is on a distinguished road
I've seen this posted elsewhere, but the solutions don't seem to apply to my case.

I'm running OpenFOAM on Ubuntu in VirtualBox. I followed the instructions to install the Ubuntu Deb pack from the OpenFOAM website: http://www.openfoam.org/download/ubuntu.php

When I run icoFoam -help, I get the usage message as expected.

However I run the tutorial using the sequence
blockMesh
icoFoam
paraFoam

blockMesh and icoFoam run without error,
but paraFoam generates the error message:
OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU
OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU

paraview opens and displays a grey 3D block.

Thanks so much for your help
vrolin is offline   Reply With Quote

Old   November 27, 2012, 07:42
Default
  #2
Member
 
Join Date: Mar 2012
Location: Munich, Germany
Posts: 67
Rep Power: 6
treima is on a distinguished road
Hello,

have you changed the settings in Paraview, that it displays the solution? From SolidColor to one of your variables?


regards

treima
treima is offline   Reply With Quote

Old   November 27, 2012, 07:49
Default Hi Treima
  #3
New Member
 
Vincent Rolin
Join Date: Nov 2012
Posts: 3
Rep Power: 6
vrolin is on a distinguished road
I haven't changed any of the settings in Paraview,
I'm new to all of the software I'm using here and wouldn't have the first clue how.
vrolin is offline   Reply With Quote

Old   November 27, 2012, 08:36
Default
  #4
Member
 
Join Date: Mar 2012
Location: Munich, Germany
Posts: 67
Rep Power: 6
treima is on a distinguished road
Play a little bit around with the parameters in Paraview or do some online research, I think that will help you a lot.

For your special case, have a look at the description of the tutorial: http://www.openfoam.org/docs/user/cavity.php#x5-40002.1


regards

treima
treima is offline   Reply With Quote

Old   November 27, 2012, 11:21
Default
  #5
New Member
 
Vincent Rolin
Join Date: Nov 2012
Posts: 3
Rep Power: 6
vrolin is on a distinguished road
Thanks again,
This helped me understand how to view results in Paraview, but when I try to look at a variable like pressure, I still only see a blank surface.
I noticed while looking at the output of icoFoam, I see a time step continuity error at several iterations.
vrolin is offline   Reply With Quote

Old   November 27, 2012, 18:19
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,748
Blog Entries: 39
Rep Power: 103
wyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of light
Greetings to all!

I'm too tired right now to go through my blog post Related issues to ParaView with OpenFOAM - Fixes and solutions
Check the links provided there and do let us know if one of them is of any help!

Good luck!
Bruno
__________________
wyldckat is offline   Reply With Quote

Old   November 30, 2012, 09:12
Default
  #7
New Member
 
Fergus
Join Date: Sep 2012
Location: Glasgow, UK
Posts: 23
Rep Power: 6
Jaggy_Snake is on a distinguished road
Is 3D acceleration turned on in your VB? I think I was getting a similar error until I disabled it... Could be wrong though
Jaggy_Snake is offline   Reply With Quote

Reply

Tags
opengl, parafoam, tutorial

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem while running in Highperformance computing environment Phanipavan STAR-CD 1 September 11, 2013 06:42
Vessel tutorial problem hosseinhgf CFX 1 March 17, 2013 12:39
Problem in running ansys fluent13 mamadou zein FLUENT 0 February 13, 2012 04:17
problem with running in parallel dhruv OpenFOAM 3 November 25, 2011 06:06
DNS Foam tutorial problem msekandi1 OpenFOAM Running, Solving & CFD 5 June 23, 2006 13:27


All times are GMT -4. The time now is 19:21.